Closed Bug 795611 Opened 7 years ago Closed 7 years ago

Background-color changed by mouse hovering doesn't clear correctly after dlbi landed

Categories

(Core :: Layout, defect)

18 Branch
x86
Windows XP
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla18
Tracking Status
firefox17 --- unaffected
firefox18 + verified

People

(Reporter: yamadat501, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(2 files)

In Bugzilla search results pages, background color of columns changes by hovering the mouse cursor.
After dlbi merge (as far as I see), background color changed by hovering doesn't clear correctly after unhovered (like attachment file).
Regression range tracking(m-i)
Last OK  :9f476b4ac1e1
First Bad:6b58397ad735

So, caused by dlbi patch groups.
Blocks: dlbi
Keywords: regression
We need to call the virtual version of this function so that the table code can overload it correctly.
Attachment #666277 - Flags: review?(roc)
Comment on attachment 666277 [details] [diff] [review]
Call the virtual InvalidateFrame from InvalidateFrameSubtree

We need a test for this.
Attachment #666277 - Flags: review?(roc) → review+
Flags: in-testsuite?
Status: RESOLVED → UNCONFIRMED
Component: General → Layout
Product: Firefox → Core
Resolution: FIXED → ---
Sorry for the mid-air mess. :/
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Confirmed fixed in mozilla-central build.

Thank you for a quick fix!
Target Milestone: --- → mozilla18
Assignee: nobody → matt.woodrow
Verified fixed in Firefox 18 beta 4.

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20121212073002
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.