Tabs not syncing from android Firefox 16 Beta to other computers

RESOLVED DUPLICATE of bug 728612

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 728612
5 years ago
7 days ago

People

(Reporter: Ian Webber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Hello,

I'm not sure if this is a Sync issues or a Firefox Beta issue, but I'll start here.

Sync is running and bookmarks and history do sync between my Samsung Galaxy Note (android 4.0.4 Firefox Beta 16) and my computers at home (Windows XP SP3 Firefox 15.0.1) and work (Windows 7 SP 1 Firefox 15.0.1), but when I go to the tabs from other computers option (about:sync-tabs) on either of the desktop computers, the mobile device is not listed with the tabs.

On the phone, the tabs from the other computers are listed, so it just seems to be an issue with the tabs from the android device being synced to the other devices.  I'm not sure if the data is making it to the server at all.

I have uninstalled Firefox Beta from the android device and reinstalled it.  I have also reset the sync data entirely (generated a new recovery key) as I'd ended up with a host of 'phantom' computers which don't exist any more and my phone was showing up several times in the devices list.

What is odd is that this did used to work, but I can't remember if that was before I changed to using the Beta on android or whether it broke on an upgrade to a newer Beta version.

Not wanting to confuse the issue, but it may be relevant, the share option to send a tab to another device, doesn't work either.  I don't know if this is related, but as they are all tabs not getting to where they should do, I thought I'd mention it.

The two desktop computers are aware of the mobile device, as it is listed if I go through the options to reset the sync data (e.g. Replace all other devices with this computer's data).

This isn't a timing issue, as I've forced the sync and the history and bookmarks will come through straight away, but the device and the open tabs on it still don't appear in the about:sync-tabs page.

Ian
Hi Ian,

Thanks for the great bug report.  Let's see if we can get to the bottom of this.  First, can you verify that you have only Firefox Beta installed?  Second, can you verify that the Account is set to Sync (i.e., Firefox Beta is checked in Android settings > Accounts & sync > your Sync account).  (This should all work, since you have tried forcing a sync, but best to check.)

The best way to diagnose this problem will be to have you post logs.  We have instructions for logging Android Sync at http://160.twinql.com/how-to-file-a-good-android-sync-bug.  Can you try that and get back to me?

Thanks again for your report!
Ian, sorry, I'm forgetful.  You're using Firefox Beta, which is 16, right?  We just landed syncing your tabs from your Android device to other devices in Firefox 18.  The relevant ticket is Bug 728612, which hit Nightly on August 30th.  So I think this is a dupe of that ticket.

If you feel comfortable, you can try Nightly to see if this works for you.  Nightly and Beta should happily co-exist (if they don't, it's a bug!), but you'll have to setup sync in Nightly again since Beta uses a different Android account.  If Nightly doesn't work well for you, you can delete it entirely and your Beta should work exactly as before.  If Nightly is a little too bleeding edge, I see that Firefox 18 will be the new Aurora on October 10th (https://wiki.mozilla.org/RapidRelease/Calendar).
(Reporter)

Comment 3

5 years ago
Thank for getting back to me.

I did have a look at the logs using aLogcat and filtered on sync. I was able to see the other bits like history uploading and downloading but there weren't ever tab items going up to the server.

As you've said that this feature has been added in a later build, I might give Aurora a go once 18 hits.

Feel free to mark this bug report appropriately and thanks for all the work you do to make Firefox great.  I rarely use anything else on my phone and desktop, the integration between the 2 is superb.

Cheers

Ian
(In reply to Ian Webber from comment #3)
> Thank for getting back to me.
> 
> I did have a look at the logs using aLogcat and filtered on sync. I was able
> to see the other bits like history uploading and downloading but there
> weren't ever tab items going up to the server.
> 
> As you've said that this feature has been added in a later build, I might
> give Aurora a go once 18 hits.

Please do -- it's really good.
 
> Feel free to mark this bug report appropriately and thanks for all the work
> you do to make Firefox great.  I rarely use anything else on my phone and
> desktop, the integration between the 2 is superb.

Thanks for the positive feedback!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 728612
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

7 days ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.