Cannot play a mp3 file from the sdcard on 9/28 otoro build - MPEG-4, MP3, AAC MIME types not recognized

RESOLVED FIXED in Firefox 18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jsmith, Assigned: eflores)

Tracking

({regression})

18 Branch
mozilla19
ARM
Gonk (Firefox OS)
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
## Build

* Device: Otoro
* Gaia: dbe752c2bc61835a92469cb0e35ad5d938a754d5
* Mozilla Central: 5e9ba780a2f3db83364a87a7b976eafe4ae834b2

## Steps

1. Put a mp3 file on your sdcard in the Music folder
2. Start the music app
3. Click the album on the mix page

## Expected

The mp3 file should begin to play

## Actual

The player loads, but the mp3 file does not start playing. The time in the player shows 00:00 for both start and end. This was working a few days ago. Did something regress?
Reporter

Updated

7 years ago
blocking-basecamp: --- → ?
Reporter

Updated

7 years ago
Summary: Cannot play a mp3 file from the sdcard on 9/28 otoro build → Cannot play a mp3 file from the sdcard on 9/28 otoro build - MPEG-4 MIME type not recognized
Reporter

Updated

7 years ago
Summary: Cannot play a mp3 file from the sdcard on 9/28 otoro build - MPEG-4 MIME type not recognized → Cannot play a mp3 file from the sdcard on 9/28 otoro build - MPEG-4, MP3, AAC MIME types not recognized
I can reproduce this on the 10-01 daily build.  This is blocking any mp3 audio to play on the Music app.   blocking+
blocking-basecamp: ? → +
Did the problem first regress in the 9/28 build?
:jsmith: what do you mean about the "mime types not recognized"? Are you seeing any kind of error message about that?
(In reply to Chris Peterson (:cpeterson) from comment #2)
> Did the problem first regress in the 9/28 build?

that was around the time that the kernal9 update was added to the otoro builds.  cc mwu, if he has thoughts.
I rolled back to the 20120927 build and I can play MP3 files on my device. The same file did not play with the 20120928 build.
Reporter

Updated

7 years ago
adityab: as far as I know, mp3s never play on b2g desktop. You really need a phone to test the music app, or you need to transcode your music to ogg.
Assignee: nobody → eflores

Comment 8

7 years ago
What's the error reported by the audio element? Edwin, did the landing of bug 759506 stop handling of "audio/mpeg" mime type?
Yeah it did. Testing patch now, should have it up in a few minutes.
Posted patch FixSplinter Review
Attachment #667222 - Flags: review?(chris.double)

Updated

7 years ago
Attachment #667222 - Flags: review?(chris.double) → review+
Duplicate of this bug: 796264
(In reply to Edwin Flores [:eflores] [:edwin] from comment #10)
> Created attachment 667222 [details] [diff] [review]
> Fix

cdouble, can you review this?   this fix has been sitting 6 days in the queue.  it's a QA blocker.   Thanks.

Comment 13

7 years ago
(In reply to Tony Chung [:tchung] from comment #12)
> cdouble, can you review this?   this fix has been sitting 6 days in the
> queue.  it's a QA blocker.   Thanks.

I reviewed it a week ago...
(In reply to Chris Double (:doublec) from comment #13)
> (In reply to Tony Chung [:tchung] from comment #12)
> > cdouble, can you review this?   this fix has been sitting 6 days in the
> > queue.  it's a QA blocker.   Thanks.
> 
> I reviewed it a week ago...

oops sorry, my bugzilla extension was still showing "Flags: review?(chris.double@double.co.nz)"   thanks!
https://hg.mozilla.org/mozilla-central/rev/8a8ef42e4b52
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Reporter

Comment 18

7 years ago
Someone on our qa team should verify this as fixed.
Keywords: verifyme
This probably also needs to land on aurora.
Hi, 

I have checked that no ringtone issue when alarm goes off.
I got some error log during it goes off.
===== log =====
E/GeckoConsole(  106): [JavaScript Warning: "HTTP "Content-Type" of "application/x-unknown-content-type" is not supported. Load of media resource app://clock.gaiamobile.org/style/ringtones/ALARM_progressive_dapple.mp3 failed." {file: "app://clock.gaiamobile.org/onring.html" line: 0}]

Is the issue related to the bug?
Or should I file another bug?
I remember the issue have been fixed for a long time.
(Bug 788204 - Gecko doesn't detect MIME type of MP3 files)
Thanks.

## Build

* Device: Otoro
* Gaia:  fb85dade07c06b1dc64c33682f52e6123ab7ee8a
* Gecko: c0ea0728044b2a5f9556ca988635140963cff037
Reporter

Updated

7 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.