Crash in mozilla::FrameLayerBuilder::ClearManagerData with MozBackfaceVisibility

RESOLVED DUPLICATE of bug 795591

Status

()

--
critical
RESOLVED DUPLICATE of bug 795591
6 years ago
6 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86_64
Mac OS X
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 666254 [details]
testcase (crashes Firefox when loaded)

1. Set
     user_pref("layers.acceleration.disabled", true);
2. Load the testcase

Result:
Crash in mozilla::FrameLayerBuilder::ClearManagerData

Probably a regression from bug 539356.  Same crash signature as bug 795591.
(Reporter)

Comment 1

6 years ago
Created attachment 666255 [details]
stack
(Reporter)

Updated

6 years ago
Crash Signature: [@ mozilla::FrameLayerBuilder::ClearManagerData]
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795591
Created attachment 666265 [details] [diff] [review]
Conversion of Jesse's testcase to a crashtest
Attachment #666265 - Flags: review?(jones.chris.g)
Comment on attachment 666265 [details] [diff] [review]
Conversion of Jesse's testcase to a crashtest

>diff --git a/layout/base/crashtests/795646.html b/layout/base/crashtests/795646.html

>@@ -0,0 +1,8 @@
>+<!DOCTYPE html>
>+<html style="position: fixed; backface-visibility: hidden;"><head>
>+<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1"></head><body onload="setTimeout(function() { 

Do we need this <meta> garbage?  Jesse's test doesn't have it.  Remove it if not necessary.

r=me with that.
Attachment #666265 - Flags: review?(jones.chris.g) → review+
You need to log in before you can comment on or make changes to this bug.