Closed Bug 795659 Opened 7 years ago Closed 7 years ago

[b2g-bluetooth] Follow-up to bug 795458

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: echou, Assigned: gyeh)

Details

Attachments

(1 file, 1 obsolete file)

The patch of bug 795458 is just a workaround, need more check to find the root cause and send a better solution.
Attached patch v1 patch (obsolete) — Splinter Review
I traced this issue and found something weird.

First, the device path is still null when creating a BluetoothDevice since we don't append device path back after retrieving device properties from dbus.

Second, we register bluetoothsignal handler twice for each BluetoothDevice: one in Create() funciton, another in constructor right after SetPropertyByValue.

These are fixed in the attachment and it should be ok to remove workaround approach in bug795659.
Assignee: nobody → gyeh
Attachment #667373 - Flags: review?(kyle)
Attachment #667373 - Flags: review?(kyle) → review+
https://hg.mozilla.org/mozilla-central/rev/f6963f19d5e9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.