Last Comment Bug 795859 - Toolbar item disappears when mouse hover.
: Toolbar item disappears when mouse hover.
Status: RESOLVED DUPLICATE of bug 787947
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 17 Branch
: x86 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
: Virgil Dicu [:virgil] [QA]
: Jet Villegas (:jet)
Mentors:
Depends on: 787947
Blocks: 779399
  Show dependency treegraph
 
Reported: 2012-10-01 04:34 PDT by Alice0775 White
Modified: 2012-10-30 19:47 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed


Attachments
screenshot (331.74 KB, image/png)
2012-10-01 04:34 PDT, Alice0775 White
no flags Details
reduced html (917 bytes, text/html)
2012-10-01 06:29 PDT, Alice0775 White
no flags Details

Description Alice0775 White 2012-10-01 04:34:00 PDT
Created attachment 666499 [details]
screenshot

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/a680fd777c3b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120930030610

I notice the problem when I test Bug 795837

Steps to reproduce:
1. Disable HWA and restart
2. Open the http://jsecs.org/
3. Zoomout(Ctrl+-) twice in my case
4. Mouse hover Back/Forward Button

Actual results:
Toolbar Items disappear.


Good:
http://hg.mozilla.org/mozilla-central/rev/f7c89de3ab43
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120915201302
Bad:
http://hg.mozilla.org/mozilla-central/rev/b3f462d96fb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916161603
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=b3f462d96fb5



Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/33087122ace7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916022601
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ee831a85d12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916033402
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33087122ace7&tochange=6ee831a85d12

Supected: Bug 788044
Comment 1 Alice0775 White 2012-10-01 04:45:07 PDT
In adittion to STR in comment #0
3-1. Scroll down if necessary.
Comment 2 Alice0775 White 2012-10-01 06:29:52 PDT
Created attachment 666522 [details]
reduced html

STR
1. Disable HWA and restart
2. Open the reduced html
3. Zoomout(Ctrl+-) three times in my case
4. Mouse hover Back/Forward Button
Comment 3 Alice0775 White 2012-10-01 16:16:17 PDT
Umm,
I can repro in Aurora17.0a2.

STR
1. Disable HWA and restart
2. Open the reduced html
3. Zoomout(Ctrl+-) several times till text "AAAAA..." disappears
4. Mouse hover Back/Forward Button

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/88ba578cbaab
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120816111151
Bad:
http://hg.mozilla.org/mozilla-central/rev/a79132ac2f05
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120816175051
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=88ba578cbaab&tochange=a79132ac2f05


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a6c9088eb267
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120816034000
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/276b57e03eba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120816040500
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a6c9088eb267&tochange=276b57e03eba

Suspected: Bug 779399
Comment 4 Alex Keybl [:akeybl] 2012-10-03 15:39:27 PDT
Assigning to roc but leaving in nominate.
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-03 21:02:32 PDT
Duplicate of bug 787947 probably
Comment 6 Alex Keybl [:akeybl] 2012-10-19 16:40:10 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #5)
> Duplicate of bug 787947 probably

QA - can you verify?
Comment 7 Virgil Dicu [:virgil] [QA] 2012-10-29 08:28:37 PDT
Could reproduce with a build before the implementation of bug 787947 and couldn't after bug 787947 landed on central. (used STR in comment 0). Checked on XP with Aurora and Nightly.

Looks fixed both on Aurora and Nightly.

*** This bug has been marked as a duplicate of bug 787947 ***

Note You need to log in before you can comment on or make changes to this bug.