If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

contenteditable areas are not displayed in Reader Mode

RESOLVED WONTFIX

Status

()

Toolkit
Reader Mode
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: xti, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Firefox 18.0a1 (2012-10-01)
Device: Galaxy Note
OS: Android 4.0.4

Steps to reproduce:
1. Go to https://etherpad.mozilla.org/FennecFlash
2. Tap on Reader Mode icon from URL bar

Actual result:
Editable content is not displayed.

Expected result:
I talked earlier with Mark Finkle on IRC about this, and his idea was to try the editable areas to be non-editable and display them as read-only document.
I think the problem is that the notes are inside of an iframe (which we don't currently support). Note that the "editable content" is not actually an editable HTML element, but instead just a <body> element (inside of the iframe) containing multiple <div>s for the text.

Updated

5 years ago
Priority: -- → P3

Updated

3 years ago
Blocks: 1102450
Component: Reader View → Reader Mode
Product: Firefox for Android → Toolkit

Comment 2

a year ago
I don't think we should add code complexity and/or spend time trying to address this. Etherpad isn't part of the primary usecases of reader mode.
Status: NEW → RESOLVED
Last Resolved: a year ago
Priority: P3 → --
Resolution: --- → WONTFIX
Summary: Editable areas are not displayed in Reader Mode → contenteditable areas are not displayed in Reader Mode

Updated

a year ago
Duplicate of this bug: 1128711
You need to log in before you can comment on or make changes to this bug.