Closed Bug 796044 Opened 9 years ago Closed 9 years ago

Firefox should get pinned to the OS taskbar after installation independent of default browser in Win8

Categories

(Firefox :: Shell Integration, defect)

x86
Windows 8
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox16 --- wontfix
firefox17 --- verified
firefox18 --- verified
firefox19 --- verified

People

(Reporter: jbecerra, Assigned: bbondy)

References

Details

(Keywords: verifyme, Whiteboard: [win8])

Attachments

(1 file)

When you install Firefox on Windows 8, the program does not get pinned to the taskbar after installation if you dismiss or say No to the default browser prompt. If you make it your default then it gets pinned.

Steps:
1. Install Firefox
2. When the program launches click on No or dismiss the default browser prompt.
3. Close the browser.

Expected: According to https://bugzilla.mozilla.org/show_bug.cgi?id=791019#c51 the browser icon should be pinned in the taskbar after installtion.

Actual: The browser icon disappears from the taskbar.

You can keep the icon if you context click on it while the program is running (even if you haven't select Firefox as your default browser).

The browser icon is also pinned by default if you click on Yes on the default browser prompt when you install it.
Whiteboard: [win8]
Jim could you take a look at this one? (I have another coming that is higher priority than this one)
This is the default behavior we currently have. We don't opin unless we're the default, and since the install doesn't set the default anymore, we don't pin initially. We do pin when the user explicitly sets us as the default through the default browser check. 

We could change this such that we always pin on initial install.
Depends on: 796038
I think making it independent of default would be good.  Probably for all platforms, but if not at least on win8.
Assignee: nobody → jmathies
I'll take this back when I get a chance to free you up for more important metro work.  Thanks for the preliminary investigations in Comment 2.
Assignee: jmathies → netzen
Summary: Firefox does not get pinned to the OS taskbar after installation unless you set the browser as default → Firefox should get pinned to the OS taskbar after installation independent of default browser in Win8
Attached patch Patch v1Splinter Review
If r+ed, after the merge I'll request this for v17 beta and v18 aurora
Attachment #668846 - Flags: review?(jmathies)
Attachment #668846 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/3113b696455b
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Comment on attachment 668846 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Windows 8 handling its own defaults
User impact if declined:  Installations will not pin an icon to the taskbar.  This pinning probably leads to more browser usage so I think we should get this in.
Testing completed (on m-c, etc.): I tested this on my win8 machine from m-c and it pinned the icon. 
Risk to taking this patch (and alternatives if risky): Very low
String or UUID changes made by this patch: None
Attachment #668846 - Flags: approval-mozilla-beta?
Attachment #668846 - Flags: approval-mozilla-aurora?
Marking qawanted just to test on a fresh win8.  Win8 does a lot of strange caching and remembering of settings so I want to make sure my testing on win8 was OK.

Note to release drivers: I see no harm in getting this on beta and aurora in the meantime though.
Keywords: qawanted
Comment on attachment 668846 [details] [diff] [review]
Patch v1

Let's get this uplifted and make sure QA verifies before Beta 4 in case there is any unexpected behaviour requiring a backout.
Attachment #668846 - Flags: approval-mozilla-beta?
Attachment #668846 - Flags: approval-mozilla-beta+
Attachment #668846 - Flags: approval-mozilla-aurora?
Attachment #668846 - Flags: approval-mozilla-aurora+
Swapping qawanted for verifyme to ensure this gets verified.
Keywords: qawantedverifyme
Verified on FF17b3, Mozilla/5.0 (Windows NT 6.2; rv:17.0) Gecko/17.0 Firefox/17.0, Build ID: 20121023124120
QA Contact: manuela.muntean
Verified on Firefox 18 beta 2, User Agent: Mozilla/5.0 (Windows NT 6.2; rv:18.0) Gecko/20100101 Firefox/18.0, Build ID: 20121128060531
Verified fixed on Firefox 19 beta 2.

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.