Closed Bug 796269 Opened 8 years ago Closed 7 years ago

[settings] set time manually once, cannot do again

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

defect

Tracking

(blocking-basecamp:+, b2g18 fixed)

VERIFIED FIXED
blocking-basecamp +
Tracking Status
b2g18 --- fixed

People

(Reporter: ghtobz, Assigned: ttaubert)

References

Details

(Keywords: reproducible, Whiteboard: [label:clock])

Attachments

(2 files)

[GitHub issue by autonome on 2012-09-29T23:51:11Z, https://github.com/mozilla-b2g/gaia/issues/5522]
STR:

1. go to Date & Time
2. turn off set automatically
3. change the time
4. click OK
5. try to change the time again

Cannot - picker doesn't open.

Workaround - toggle set automatically again
[GitHub comment by autonome on 2012-09-29T23:52:59Z]
/cc @ian-liu
[mass adding reproducible keyword for any open Gaia bug with the word "STR:" in comments]
Keywords: reproducible
still reproducible, and will both date and time. i have to hit a bunch of times before it opens the pickers.
Taking a look at this.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #669439 - Flags: review?(iliu)
The problem here seems to be that the FormAssistant doesn't know that the "keyboard" (date/time picker) has been closed. So it won't open another one unless you somehow manage to focus another element that resets this status.
Attachment #669442 - Flags: review?(21)
Attachment #669439 - Flags: review?(iliu) → review+
https://hg.mozilla.org/integration/fx-team/rev/61e0ba0e9165
Whiteboard: [label:clock] → [label:clock][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/61e0ba0e9165
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [label:clock][fixed-in-fx-team] → [label:clock]
Otoro daily: 10-11-2012
* gaia: 2667536e3b06e46dd193aa6d76ba08dad2d867be
* gonk: 6ec34aa3d66331054de37eabc594ad923654b27c

Still busted.  Picker doesn't open.   Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Works for me on my dev build. Does gonk somehow need to be updated for the daily builds? Is this automatically pulled from Aurora now?
Blocks: 796787
Priority: -- → P1
According to Ian, the fix doesn't really fix what described in STR, but rather Keyboard API feature planned in bug 793108 can.
Depends on: 793108
Still fixed for me. By whatever patch.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Verified on the 10/22 build that user can set & re-set the time without issue.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.