Closed Bug 796277 Opened 8 years ago Closed 8 years ago

[Dialer] holding number 1 on the keypad does not go to voice mail anymore

Categories

(Core :: DOM: Device Interfaces, defect, P1)

defect

Tracking

()

RESOLVED FIXED
B2G C1 (to 19nov)
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: ghtobz, Assigned: chucklee)

References

Details

(Keywords: feature, Whiteboard: [label:dialer][label:blocked][label:needsGeckoSupport])

Attachments

(1 file, 2 obsolete files)

[GitHub issue by nhirata on 2012-08-01T23:26:08Z, https://github.com/mozilla-b2g/gaia/issues/3088]
## Environment :
Otoro phone, build 2012-08-01
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 9d84ba558d495cb515d38bd1b4327b7bd3577854
* "gaia" revision= 91588ac7f94b9c3a74cbccd30f106b1616d03df6
* "mozilla-central" revision= 8f5bbf2de08edd6df2e5d1871a5a2e8a58372151
* "gonk-misc" revision= 23709ac8cf937422eca4f38d69f62cddb8270353

## Repro :
1. go into dialer app
2. hold the 1 key

## Expected :
* tone for one happens and then connected to voice mail

## Actual :
* tone for one happens and then nothing

## Note :
* regression was working yesterday
[GitHub comment by etiennesegonzac on 2012-08-02T10:06:32Z]
@marshall I'm having a really hard time getting the mozVoicemail to give me a number too.
Could we help you investigate?

@nhirata could you try again while making sure that you can make call (have good reception)?
[GitHub comment by nhirata on 2012-08-02T14:46:08Z]
@etiennesegonzac, I was able to make a call out to my own cell phone.  I was not able to make a call out to voicemail by holding 1.
[GitHub comment by vingtetun on 2012-08-16T19:50:15Z]
@etiennesegonzac Can you open a bugzilla issue if that does not work and CC @marshall ?
[GitHub comment by etiennesegonzac on 2012-08-17T09:33:33Z]
@vingtetun I was never able to get it to work with my french sim card so I cannot see if it regressed or not.

I think we need @marshall to take a look and close this gaia issue if it's gecko related.
[GitHub comment by marshall on 2012-08-17T19:05:34Z]
@vingtetun @etiennesegonzac @nhirata hey guys, I somehow missed this :(

@nhirata do you have details about what kind of SIM you are using? I will try this on the latest with my T-Mobile US sim later today and see if I can verify
[GitHub comment by arcturus on 2012-08-19T18:16:11Z]
@etiennesegonzac apparently depends on the countries/operators. Telefonica in Spain apparently is adding it to the sim card by default.

@jaoo and @chrisvargauk have been working on this, perhaps they could add more info.

Cheers!
[GitHub comment by marshall on 2012-08-24T15:35:51Z]
hey guys, I was able to confirm that long-pressing 1 on my otoro w/ T-Mobile US sim is no longer working. I'll see if I can find the cause today
[GitHub comment by jaoo on 2012-08-24T15:44:53Z]
Carriers may not include the voice mail number in the ICC card. @marshall I guess you are sure your ICC has that number stored in the SIM. I double confirm that is also happening on my side. I would like also alert you guys about a bug [1] there is while fetching ICC records from SIM ICC Cards. If your ICC card is USIM ICC card there is no problem.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=785095
[GitHub comment by nhirata on 2012-09-05T22:41:00Z]
This is still an issue:
Otoro phone, build 2012-09-05
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 76e88b579737d7b5078063dcbec60c2ad2c70465
* "gaia" revision= 279a13474955c1bc58082c8f3c6f54cf09d8c396 
* "mozilla-central" revision= 566ea2b9de39e8b9b18513931fc1cb1825535f3a
* "gonk-misc" revision= a9b6133e492017d34703ae3f24ea1fa9349cbcce
[GitHub comment by jcarpenter on 2012-09-22T22:36:01Z]
Still not working on my 9/20 build.
Tested with a build from 10/01 and this is working for me on Otoro with T-Mobile US SIM. 

It doesn't work with an AT&T SIM though. It looks like this SIM doesn't have the MBDN record, which is valid.

We probably need UX guidance on what to do if/when a MBDN isn't provided. Josh do you have any thoughts?

IIRC Jose also provided a mechanism to fallback in case the MBDN wasn't on the card (i.e. a way to override MBDN through a device setting)
> We probably need UX guidance on what to do if/when a MBDN isn't provided. Josh do you have any thoughts?

Sorry, I do not.

I will ask Rafa to chime in. He is working on SIM issues and also taking over Dialer UX from original owner Ayman, who just had a baby.
I guess:

a) The first tap and hold offers a prompt for the user to fill it in
b) Remove the VM icon from the number 1 key in case the SIM doesn't provide any
(In reply to Marshall Culpepper [:marshall_law] from comment #11)
> IIRC Jose also provided a mechanism to fallback in case the MBDN wasn't on
> the card (i.e. a way to override MBDN through a device setting)

Yes, you're right. The mechanism gets the number from the service provider database if it's not included in the ICC card. If that's not working for AT&T ICC card could be i) the operator may not included it in the SIM and ii) there's not voicemail number info in the service provider database for that operator (AT&T).

I'll be happy to take a look at the operator info in that service provider database if any of you guys provide me the MCC and MNC codes for that operator.
(In reply to hello from comment #13)
> b) Remove the VM icon from the number 1 key in case the SIM doesn't provide
> any

I'm afraid we cannot do that because (AFAIK) it's a requirement for phone certification.
Summary: [regression][Dialer] holding 1 does not go to VM → [Dialer] holding number 1 on the keypad does not go to voice mail anymore
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #14)
> (In reply to Marshall Culpepper [:marshall_law] from comment #11)
> > IIRC Jose also provided a mechanism to fallback in case the MBDN wasn't on
> > the card (i.e. a way to override MBDN through a device setting)
> 
> Yes, you're right. The mechanism gets the number from the service provider
> database if it's not included in the ICC card. If that's not working for
> AT&T ICC card could be i) the operator may not included it in the SIM and
> ii) there's not voicemail number info in the service provider database for
> that operator (AT&T).

Is the service provider database something Gaia will need to look at, or do we need to integrate it into the RIL implementation? 
 
> I'll be happy to take a look at the operator info in that service provider
> database if any of you guys provide me the MCC and MNC codes for that
> operator.

AT&T US MCC: 310 MNC: 410
(In reply to Marshall Culpepper [:marshall_law] from comment #16)
> Is the service provider database something Gaia will need to look at, or do
> we need to integrate it into the RIL implementation? 

We ship this database with Gaia and do not to integrate anything about it into the RIL. See that database at [1].

>  
> > I'll be happy to take a look at the operator info in that service provider
> > database if any of you guys provide me the MCC and MNC codes for that
> > operator.
> 
> AT&T US MCC: 310 MNC: 410

There is no <voicemail> info for such provider (carrier). A quick fix would be to add it. 

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/serviceproviders.xml
Priority: -- → P1
Priority: P1 → --
Priority: -- → P1
This also doesn't work for me using a Speakout (Rogers MVNO) SIM in Canada. Let me know if you need me to provide any additional info or try anything.
We're marking this bug with the C1 milestone since it follows the criteria of "unfinished feature work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Keywords: regression
Target Milestone: --- → B2G C1 (to 19nov)
Keywords: feature
This bug depends on bug 806307 and apart from that the Phone application is unable to retrieve the mozVoicemail.{number, displayName} properties running OOP.
Depends on: 806307
Assignee: marshall → nobody
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #20)
> This bug depends on bug 806307 and apart from that the Phone application is
> unable to retrieve the mozVoicemail.{number, displayName} properties running
> OOP.

Do you know why it is unable to retrieve it OOP?
(In reply to Vivien Nicolas (:vingtetun) from comment #21)
> (In reply to José Antonio Olivera Ortega [:jaoo] from comment #20)
> > This bug depends on bug 806307 and apart from that the Phone application is
> > unable to retrieve the mozVoicemail.{number, displayName} properties running
> > OOP.
> 
> Do you know why it is unable to retrieve it OOP?

It seems like this is a platform bug. All the Gaia code is in place to handle it. Moving to the right component.
Component: Gaia → DOM: Device Interfaces
Product: Boot2Gecko → Core
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #20)
> This bug depends on bug 806307 and apart from that the Phone application is
> unable to retrieve the mozVoicemail.{number, displayName} properties running
> OOP.

cjones, you have any hint or idea or something in mind that could be the cause of the problem around OOP? I'll be happy to help here but I don't know how to start poking around.
Marshall, per your comment 11, can you please find out if Telephonica provides the MBDN record that is required for the dial to voicemail to work?
Assignee: nobody → marshall
(In reply to Lawrence Mandel [:lmandel] from comment #24)
> Marshall, per your comment 11, can you please find out if Telephonica
> provides the MBDN record that is required for the dial to voicemail to work?

That's a fallback mechanism in case the MBDN wasn't on the ICC card. The problem here is that the mozVoicemail API doesn't work OOP since the phone app runs OOP. BTW, the database containing voicemail numbers used in the fallback mechanism lives at https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/apn.json.
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #25)
> The problem here is that the mozVoicemail API doesn't work OOP since the
> phone app runs OOP.

That sounds really bad... Is there a bug on file for this?
(In reply to ben turner [:bent] from comment #26)
> (In reply to José Antonio Olivera Ortega [:jaoo] from comment #25)
> > The problem here is that the mozVoicemail API doesn't work OOP since the
> > phone app runs OOP.
>

The only way I was able to make it work was by adding the phone app here [1].
 
> That sounds really bad... Is there a bug on file for this?

Nope. This one is valid, isn't it?

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/window_manager.js#L976
Chuck, as you fixed bug 806307 which depended by this one, would you also take this bug?

As Jose mentioned, the problem here is the mozVoicemail API doesn't work when running OOP.  For OOP issue, you may discuss with Hsinyi or Vicamo who has experience on related bug before.
Assignee: marshall → chulee
1. Integrate voicemail info(number and display name, currently) into icc info.
2. Handle iccmbdn and save voicemail info in RIL, so every RILContentHelper can get these info.
3. Update voicemail info by iccInfoUpdate.
Attachment #684337 - Flags: review?(allstars.chh)
Attached patch Save voicemail info in RIL (obsolete) — Splinter Review
1. Handle iccmbdn and save voicemail info in RIL, so every RILContentHelper can get these info.
2. Change RIL:VoicemailNumberChanged to RIL:VoicemailInfoChanged for general useage.
Attachment #684337 - Attachment is obsolete: true
Attachment #684337 - Flags: review?(allstars.chh)
Attachment #684357 - Flags: review?(allstars.chh)
Attachment #684357 - Flags: review?(allstars.chh) → review?(htsai)
Comment on attachment 684357 [details] [diff] [review]
Save voicemail info in RIL

Review of attachment 684357 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great, thanks! Please remember to revise the patch description.
Attachment #684357 - Flags: review?(htsai) → review+
Change reviewer's name in patch after review+.
Attachment #684357 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/a355e0709bc2
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-beta/rev/788b4f934d72

(This is also in my queue to land on Aurora once it reopens)
@chucklee I don't see a corresponding change in nsIRadioInterfaceLayer.idl file to introduce voicemail in nsIRilConext. Am I missing something?
Adding voicemail in RILContext here is solving voicemail data lost to new created RILContentHelper. So it is for storing voicemail data in RadioInterfaceLayer which will be passed to RILContentHelper through IPC while RILContentHelper is created. Then app can get voicemail info by MozVoicemail(which gets voicemail info from RILContenHelper) correctly.
So exposing the interface is not necessary in this bugfix.
I've filed Bug 820762 to expose the interface.
You need to log in before you can comment on or make changes to this bug.