Closed Bug 796453 Opened 10 years ago Closed 10 years ago

[keyboard] dragging the finger upward across a couple of keys will leave the top number displayed

Categories

(Firefox OS Graveyard :: Gaia, defect, P3)

defect

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 799644
blocking-basecamp +

People

(Reporter: ghtobz, Assigned: vingtetun)

References

Details

(Whiteboard: [label:Keyboard & IME])

[GitHub issue by nhirata on 2012-08-01T00:07:11Z, https://github.com/mozilla-b2g/gaia/issues/3031]
## Environment :
Otoro phone, build 2012-07-31
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 9d84ba558d495cb515d38bd1b4327b7bd3577854
* "gaia" revision= 0f0e021cac3e19693739b31190c0bef287c27c42
* "mozilla-central" revision= 05690cf0d2c2ae6cfa75a480c4834356e0782314
* "gonk-misc" revision= 8ceaeb8117b57327dad648aa498a6595d5e2e55a

## Repro :
1. go to UI Tests
2. tap into Input type=tel:
3. drag finger from # upwards to 3 and let go
4. do the same for 0 to 2, and * to 1...

## Expected :
* top number will disappear

## Actual :
* number is left on the screen

## Note :
* http://www.flickr.com/photos/54171535@N05/7687741080/in/photostream
[GitHub comment by nhirata on 2012-08-01T00:08:23Z]
Chances are not many people will do this..  if you press the button by itself or only drag across 2 keys, it won't show.  you need to drag your finger across through 3 buttons.  I am not noming because of the restriction.
[GitHub comment by nhirata on 2012-08-01T00:15:37Z]
Interestingly... you can do this on a regular keyboard as well.

http://www.flickr.com/photos/54171535@N05/7687787232/in/photostream
[GitHub comment by vingtetun on 2012-08-01T09:01:31Z]
On 01/08/2012 02:07, nhirata wrote:
> ## Environment :
> Otoro phone, build 2012-07-31
> Taken from default.xml in b2g-distro:
> * "platform_build" revision= 9d84ba558d495cb515d38bd1b4327b7bd3577854
> * "gaia" revision= 0f0e021cac3e19693739b31190c0bef287c27c42
> * "mozilla-central" revision= 05690cf0d2c2ae6cfa75a480c4834356e0782314
> * "gonk-misc" revision= 8ceaeb8117b57327dad648aa498a6595d5e2e55a
>
> ## Repro :
> 1. go to UI Tests
> 2. tap into Input type=tel:
> 3. drag finger from # upwards to 3 and let go
> 4. do the same for 0 to 2, and * to 1...
>
> ## Expected :
> * top number will disappear
>
> ## Actual :
> * number is left on the screen

Will be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=774190

> ## Note :
> * http://www.flickr.com/photos/54171535@N05/7687741080/in/photostream
>
> ---
> Reply to this email directly or view it on GitHub:
> https://github.com/mozilla-b2g/gaia/issues/3031
[GitHub comment by autonome on 2012-09-26T05:34:09Z]
that platform bug was fixed over a month ago, and someone just reproduced this in triage the other day.
Duplicate of this bug: 796752
Priority: -- → P3
Taking for now. I will have some fun with the keyboard and I would like to fix this in the same row.
Assignee: nobody → 21
Vivien,

I'm in the middle of a major refactor of the keyboard code right now, so please coordinate your changes with me.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799644
You need to log in before you can comment on or make changes to this bug.