[homescreen] I can slide icons on the fast dial even if I'm not in "moving icon mode"

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: ghtobz, Unassigned)

Tracking

({reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:homescreen][label:needsUXinput])

(Reporter)

Description

6 years ago
[GitHub issue by mounirlamouri on 2012-08-23T23:55:02Z, https://github.com/mozilla-b2g/gaia/issues/3774]
STR:
1. move an icon in the fast dial
2. slide your finger on that area

Actual result: the icon will slide
Expected result: nothing should happen
(Reporter)

Comment 1

6 years ago
[GitHub comment by nhirata on 2012-08-24T18:24:37Z]
I'm not sure if this is a bug.  I was under the impression that we might actually put more in the dock and also have the dock swivel in a possible later version?

@jcarpenter ?
(Reporter)

Comment 2

6 years ago
[GitHub comment by jcarpenter on 2012-08-27T06:53:54Z]
@mounirlamouri Let's discuss this one Monday in Sao Paulo WW. I want to make sure I understand the issue being discussed. As @nhirata points out, we do have a scrolling dock now, but I'm not sure if that's the issue.
(Reporter)

Comment 3

6 years ago
[GitHub comment by mounirlamouri on 2012-08-27T14:12:40Z]
Yes, the scrolling dock is weird. Seems like it is by design though. Did you do user testing? I might be surprised because I'm using Android and Android has a dock but not scrolling.
(Reporter)

Comment 4

6 years ago
[GitHub comment by nhirata on 2012-08-27T15:42:36Z]
Neither Android nor iPhone has a scrolling dock.  I think we would be the first.
(Reporter)

Comment 5

6 years ago
[GitHub comment by jcarpenter on 2012-09-04T07:55:55Z]
> Neither Android nor iPhone has a scrolling dock. I think we would be the first.

I believe that's correct :) The TEF home screen UX concepts originally spec'd a more ambitious Carousel with live content previews. The current dock is a descendant of that approach. The idea is that over time users will populate the dock with the 4-9 apps they use most frequently, skipping the need to access the full Grid.

Comment 6

6 years ago
[mass adding reproducible keyword for any open Gaia bug with the word "STR:" in comments]
Keywords: reproducible

Updated

6 years ago
Component: Gaia → Gaia::Homescreen
We do in-fact have a sliding dock. Please reopen with additional details if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.