XML error when archiving a message on Gmail

RESOLVED DUPLICATE of bug 1036987

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1036987
6 years ago
4 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

({reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:email][label:email-ui])

(Reporter)

Description

6 years ago
[GitHub issue by etiennesegonzac on 2012-09-09T17:25:23Z, https://github.com/mozilla-b2g/gaia/issues/4481]
STR:

- log to a gmail account from the gaia browser
- select a mail
- click "Archive" (links at the bottom of the page)

We get a big ugly gecko-looking XML error.

Not sure where it comes from and if a gecko bug should be filed, ping @jlebar ?
(Reporter)

Comment 1

6 years ago
[GitHub comment by jlebar on 2012-09-09T21:21:13Z]
I can't test this atm because wifi is broken on my device.

If you have a chance, what does the error message say?  It could be that we're running out of memory and, instead of crashing, we do something funky which results in an error.
(Reporter)

Comment 2

6 years ago
[GitHub comment by etiennesegonzac on 2012-09-10T09:55:29Z]
It's not showing up in screen-shots, but approximately :

```
XML Parsing Error: not well-formed
Location: https://mail.google.com...
Line Number 27, Column 53:

The conversation has been archived   [some html fragment probably meant to be placed in the dom]
```
(Reporter)

Comment 3

6 years ago
[GitHub comment by jlebar on 2012-09-10T19:40:07Z]
@bzbarsky This is pretty bizarre.  Do you have any idea what might be going on here?  This doesn't smell like OOM to me...
(Reporter)

Comment 4

6 years ago
[GitHub comment by bzbarsky on 2012-09-10T20:59:16Z]
The most likely cause is browser sniffing combined with buggy (possibly undertested) codepaths on the server.  Does spoofing the desktop Firefox UA change the behavior?
(Reporter)

Comment 5

6 years ago
[GitHub comment by etiennesegonzac on 2012-09-12T14:30:49Z]
Yep we get the full version (pretty unusable) when spoofing the UA but archiving works ;)
(Reporter)

Comment 6

6 years ago
[GitHub comment by bzbarsky on 2012-09-12T16:24:26Z]
OK.  Want to run a packet sniffer while doing the steps from comment 0 (hey, too bad Github's issue tracker doesn't number or linkify the comments....) and seeing what the server returns exactly?

Comment 7

6 years ago
[mass adding reproducible keyword for any open Gaia bug with the word "STR:" in comments]
Keywords: reproducible

Comment 8

4 years ago
Seem.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036987
You need to log in before you can comment on or make changes to this bug.