Closed Bug 796890 Opened 8 years ago Closed 8 years ago

Create Mochitest for Video/Audio connection (send/disconnect)

Categories

(Core :: WebRTC, defect)

18 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [WebRTC][blocking-webrtc+][qa-])

Attachments

(1 file, 2 obsolete files)

As part of the initial landing of the WebRTC feature some smoketests should ensure the basics for the Peer Connection feature are working. This bug covers the request for the following test:

Ensure a local video and audio connection works:

* The connection can be established
* Packages can be send/received for video
* Packages can be send/received for audio
* Disconnect
Whiteboard: [WebRTC], [blocking-webrtc+]
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Whiteboard: [WebRTC], [blocking-webrtc+] → [WebRTC][blocking-webrtc+]
Version: 14 Branch → 18 Branch
Attached patch WIP (obsolete) — Splinter Review
This is a WIP patch for now. It's not ready yet but important for another bug as a testcase. So I have already uploaded it. I will finish it up once the before mentioned bug has been fully investigated.
Depends on: 773649
Summary: Create Mochitest for Video/Audio connection (send/receive/disconnect) → Create Mochitest for Video/Audio connection (send/disconnect)
I think that I should wait for bug 818714 been fixed until I finish up this test. Otherwise it would have to be changed right away.
Depends on: 818714
Attached patch WIP v2 (obsolete) — Splinter Review
Updated WIP without the changes necessary for bug 818714 implemented yet. Once the patch on that bug has been landed I will finalize my two tests.
Attachment #668414 - Attachment is obsolete: true
Attached patch Patch v1Splinter Review
Attachment #694145 - Attachment is obsolete: true
Attachment #694368 - Flags: review?(rjesup)
This test should be landed with the patch on bug 818714.
Whiteboard: [WebRTC][blocking-webrtc+] → [WebRTC][blocking-webrtc+][land with bug 818714]
Attachment #694368 - Flags: review?(rjesup) → review+
Duplicate of this bug: 824357
https://hg.mozilla.org/mozilla-central/rev/a395e2d60c16
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [WebRTC][blocking-webrtc+][land with bug 818714] → [WebRTC][blocking-webrtc+]
Target Milestone: --- → mozilla20
Whiteboard: [WebRTC][blocking-webrtc+] → [WebRTC][blocking-webrtc+][qa-]
You need to log in before you can comment on or make changes to this bug.