Scrollbar does not work in table cell - overflow auto

RESOLVED DUPLICATE of bug 796945

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 796945
6 years ago
6 years ago

People

(Reporter: oliver.stiefbold, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 667015 [details]
firefoxScrollbarBug.html

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)

Steps to reproduce:

Example:
There are two content areas below. Both are nested in a scroll area (DIV with overflow:auto). The scroll areas are nested in a table with two rows each taking 50% of the table space. The content areas should use the available space (100% height and width) to draw their metrics until their content is larger than the available space defined in the scroll areas. From this point on scrollbars should appear.
Content are 1 has less content. Content Area 2 has content which is larger than the surrounding scroll area.



Actual results:

Scrollbar in window.




Expected results:

Scrollbar in table cell

All browsers are doing that properly except FireFox. It expands Content Area 2and no scrollbars do appear.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796945
You need to log in before you can comment on or make changes to this bug.