All users were logged out of Bugzilla on October 13th, 2018

"background-clip: content-box, border-box" does not seem to work

RESOLVED FIXED in Firefox 18

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bzbarsky, Assigned: cwiiis)

Tracking

({regression})

unspecified
mozilla19
x86
Mac OS X
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox16 unaffected, firefox17 unaffected, firefox18+ fixed, firefox19+ fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

testcase, to run from the srcdir:

<style>
  div { background-image: url(layout/reftests//backgrounds/aqua-32x32.png),
                          url(layout/reftests//backgrounds/green-16x20.png);
        border: 20px solid transparent;
        background-clip: content-box, border-box;
        width: 100px; height: 100px; }
</style>
<div></div>

This shows only aqua, no green.  That seems broken to me...
Also seeing this, works on beta (17), broken on aurora(18).
(Reporter)

Comment 2

6 years ago
Oh, interesting!  I didn't realize this used to work.

Hector, are you willing to find a regression range?
status-firefox16: --- → unaffected
status-firefox17: --- → unaffected
status-firefox18: --- → affected
status-firefox19: --- → affected
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
Keywords: regression, regressionwindow-wanted
(In reply to Boris Zbarsky (:bz) from comment #2)
> Oh, interesting!  I didn't realize this used to work.
> 
> Hector, are you willing to find a regression range?

I'd like to, just need to be patient for the slow downloading.
(Reporter)

Comment 4

6 years ago
OK.  Let me know if you're having trouble with it, alright?
(In reply to Boris Zbarsky (:bz) from comment #2)
> Oh, interesting!  I didn't realize this used to work.
> 
> Hector, are you willing to find a regression range?

And the regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f36b93c70d05&tochange=e5af3d785252
(Reporter)

Comment 6

6 years ago
Hmm.  Probably a regression from bug 786502, then.

Chris, can you take a look?
Blocks: 786502
Keywords: regressionwindow-wanted

Updated

6 years ago
Assignee: nobody → chrislord.net
tracking-firefox18: ? → +
tracking-firefox19: ? → +
(Assignee)

Comment 7

6 years ago
Created attachment 677367 [details] [diff] [review]
Fix border clipping on backgrounds with multiple layers

Fix the issue. reftest patch incoming.
Attachment #677367 - Flags: review?(roc)
(Assignee)

Comment 8

6 years ago
Created attachment 677375 [details] [diff] [review]
Reftest

Turn the test case in comment #0 into a reftest.
Attachment #677375 - Flags: review?(roc)
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

6 years ago
hmm, not quite, this breaks another reftest...

https://tbpl.mozilla.org/?tree=Try&rev=bef23e002e21
(Assignee)

Comment 10

6 years ago
Created attachment 677436 [details] [diff] [review]
Fix border clipping on backgrounds with multiple layers

Remember to draw all layers when aLayer < 0.
Attachment #677367 - Attachment is obsolete: true
Attachment #677367 - Flags: review?(roc)
Attachment #677436 - Flags: review?(roc)
Comment on attachment 677436 [details] [diff] [review]
Fix border clipping on backgrounds with multiple layers

Review of attachment 677436 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #677436 - Flags: review?(roc) → review+
(Assignee)

Comment 13

6 years ago
Will wait over the weekend, then assuming there are no problems, request aurora approval.
(Assignee)

Comment 14

6 years ago
Silly signed/unsigned follow-up to fix debug build bustage:

https://hg.mozilla.org/integration/mozilla-inbound/rev/772a4bb004ad
https://hg.mozilla.org/mozilla-central/rev/da40e6f95147
https://hg.mozilla.org/mozilla-central/rev/324d0fbac2fd
https://hg.mozilla.org/mozilla-central/rev/772a4bb004ad
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-firefox19: affected → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to Chris Lord [:cwiiis] from comment #13)
> Will wait over the weekend, then assuming there are no problems, request
> aurora approval.

Hi,

Any ETA of this aurora uplift? Thanks!
(Assignee)

Comment 17

6 years ago
Comment on attachment 677436 [details] [diff] [review]
Fix border clipping on backgrounds with multiple layers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): border clipping on multi-layer backgrounds breaks.
User impact if declined: Using this feature will result in incorrect rendering
Testing completed (on m-c, etc.): Been on m-c a while now with no apparent ill effect
Risk to taking this patch (and alternatives if risky): Low-Medium. I'd have thought breakage ought to be obvious, but I wouldn't want to assume.
String or UUID changes made by this patch: None.
Attachment #677436 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 18

6 years ago
Comment on attachment 677375 [details] [diff] [review]
Reftest

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Test-case for the feature this bug fixes
User impact if declined: We may accidentally break this feature(?)
Testing completed (on m-c, etc.): Reftest has been running fine since push.
Risk to taking this patch (and alternatives if risky): Practically nil.
String or UUID changes made by this patch: None.
Attachment #677375 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 19

6 years ago
Thanks for the reminder, Hector, I'd totally forgotten!

Updated

6 years ago
Attachment #677375 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

6 years ago
Attachment #677436 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.