Port Telemetry tests to mochitests

RESOLVED DUPLICATE of bug 808161

Status

()

Toolkit
Telemetry
RESOLVED DUPLICATE of bug 808161
6 years ago
6 years ago

People

(Reporter: Yoric, Assigned: Yoric)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Telemetry tests are currently xpcshell. This makes Telemetry incompatible with workers and OS.File. We should port them to mochitests before we consider porting Telemetry I/O to OS.File.
Assignee: nobody → dteller
Created attachment 669122 [details] [diff] [review]
Porting test_nsITelemetry.js

Porting test_nsITelemetry.js. Some of the conversion was done manually, some with regexps. Taras, what do you think of the result?

A few notes:
- there were a number of errors and inconsistencies in the original code, I have tried to fix them along the way;
- atm, this test leaks a string buffer – not quite sure where.
Attachment #669122 - Flags: feedback?(taras.mozilla)

Comment 2

6 years ago
Comment on attachment 669122 [details] [diff] [review]
Porting test_nsITelemetry.js

Nathan owns this now.
Attachment #669122 - Flags: feedback?(taras.mozilla) → feedback?(nfroyd)
Comment on attachment 669122 [details] [diff] [review]
Porting test_nsITelemetry.js

Review of attachment 669122 [details] [diff] [review]:
-----------------------------------------------------------------

Looks sane enough to me.
Attachment #669122 - Flags: feedback?(nfroyd) → feedback+
There is ongoing work to make Components go away...I can't find the bug right now, my searches are not working in bugzilla or zimbra.  I'm sure folks would appreciate if you looked up what was going on there and tried to write the tests according to the New World Order. :)
TUrns out that we may not need this at all: bug 808161.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 808161
You need to log in before you can comment on or make changes to this bug.