Closed Bug 797334 Opened 7 years ago Closed 7 years ago

Click-to-play plugin activation panel: panel background doesn't match panel arrow color on Windows, arrow lacks border on Linux

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox17 --- verified

People

(Reporter: dao, Assigned: dao)

References

Details

Attachments

(3 files)

Attached image screenshot (Windows)
No description provided.
It looks like bug 754472 wanted pretty much the whole panel to be lighter except for the list of plugins. This is bogus. We should just leave alone the color of the part the arrow connects with. We should also get rid of panelarrow-light-vertical.svg that bug 754472 added for gnomestripe.

This should get this mostly back in shape and make it maintainable. Generally though, the browser-specific styling added in bug 754472 is so fragile that it will break whenever someone touches the arrow panel styling in toolkit.
Dao - I can't reproduce this. Is this a local build or a nightly? Also, what OS? (looks like Windows 7, but that's what I'm using, and the arrow is correct for me).

With regard to the design of the popup, you'll have to talk to Stephen Horlander.
Nightly, Windows 7. Note that Windows 7 ships with multiple themes.
(In reply to Dão Gottwald [:dao] from comment #1)
> Generally though, the browser-specific styling added in bug 754472 is so
> fragile that it will break whenever someone touches the arrow panel styling
> in toolkit.

It didn't take long for this to happen: bug 795812
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #667956 - Flags: review?(enndeakin)
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Panel background doesn't match panel arrow color in click-to-play plugin activation panel → Click-to-play plugin activation panel: panel background doesn't match panel arrow color on Windows, arrow lacks border on Linux
Attachment #667454 - Attachment description: screenshot → screenshot (Windows)
Comment on attachment 667956 [details] [diff] [review]
patch

<shorlander> gavin: that said I would like to update all notification panels to look the same so we could defer exactly what that looks like until later.
Attachment #667956 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/mozilla-central/rev/1e6444704d70
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Two questions:

Do we want to do this for pinstripe as well?

Do we want to uplift this to 17?
Comment on attachment 667956 [details] [diff] [review]
patch

The Linux issue shouldn't affect 18, but the Windows issue does.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 754472
User impact if declined: visual glitch in the appearance of the click-to-play panel
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): no risk
String or UUID changes made by this patch: none
Attachment #667956 - Flags: approval-mozilla-beta?
Comment on attachment 667956 [details] [diff] [review]
patch

since CTP is a feature starting in 17, let's get this visual glitch fix uplifted.
Attachment #667956 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
What's the expected design? I see the second one from https://bug797334.bugzilla.mozilla.org/attachment.cgi?id=667965 on all OSs.
Paul, both images are basically the same, it's just changes based on the Windows theme. If you are using Windows Classic, you should see the top image; otherwise you should see the bottom image. However, they are essentially the same.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #15)
> Paul, both images are basically the same, it's just changes based on the
> Windows theme. If you are using Windows Classic, you should see the top
> image; otherwise you should see the bottom image. However, they are
> essentially the same.

What I meant to say was look at the first screenshot attached to this bug. The arrow is a slightly different shade of gray than the rest of the doorhanger. If what you see looks like either of the images in the second screenshot then this bug is fixed. I'm marking this verified based on the fact you indicated as much in comment 14.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.