Last Comment Bug 797364 - Stagefright: Galaxy SII & Galaxy Note hardware decoder video yields green layer over video
: Stagefright: Galaxy SII & Galaxy Note hardware decoder video yields green lay...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 18 Branch
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://people.mozilla.com/~atrain/mob...
Depends on: 785275
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 08:12 PDT by Aaron Train [:aaronmt]
Modified: 2012-10-18 06:49 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-
affected
affected
fixed
17+


Attachments
Samsung Galaxy SII (Android 4.0.4) (Nightly 10/03) - Screenshot (199.42 KB, image/png)
2012-10-03 08:12 PDT, Aaron Train [:aaronmt]
no flags Details

Description Aaron Train [:aaronmt] 2012-10-03 08:12:05 PDT
Created attachment 667489 [details]
Samsung Galaxy SII (Android 4.0.4) (Nightly 10/03) - Screenshot

Using the test-case in the bug URL; will yield varying results from the OMXCodec playback (H.264/MPEG-4 AVC) with following results.

* Samsung Galaxy SII (Android 4.0.4) & Samsung Galaxy Note (Android 4.0.4)
** Hardware decoding: visible green layer, see attached screenshot
** Software decoding: no issues

Aurora is affected, so this is not any regression from bug 784329.

--
Samsung Galaxy SII (Android 4.0.4)
Mozilla-Central (Nightly, 10/03)
Comment 1 Chris Peterson [:cpeterson] 2012-10-03 10:35:47 PDT
If a video has green bars or "ghosting", that means we need to write a color conversion function for that particular device's hardware decoder.

We may find that this bug is a dupe of Galaxy S III bug 785275. The Galaxy Note, S II, and S III have similar chipsets, but I've read that their hardware decoders may each have different "quirks" we need to work around.
Comment 2 cajbir (:cajbir) 2012-10-09 20:48:10 PDT
The fix in bug 785275 fixes this issue on the Galaxy Note for me.
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-10-11 12:29:36 PDT
qawanted to see if bug 785275 fixed this on the note, SII and SIII
Comment 4 Aaron Train [:aaronmt] 2012-10-11 13:00:04 PDT
Fixed via bug 785275
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-12 15:22:07 PDT
nothing in here to track, uplift nominations welcome in bug 785275

Note You need to log in before you can comment on or make changes to this bug.