FrameMetrics == operator is broken

RESOLVED FIXED in mozilla18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

Trunk
mozilla18
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

7 years ago
At some point, someone changed the FrameMetrics == operator to not check the resolution. Or perhaps it was always broken, but some other element of it has stopped changing at the same time as resolution. Anyway, this breaks retained tiles on Firefox Mobile on Android and makes it quite hard to do a few other things too - If for whatever reason there needs to be a FrameMetrics comparison that doesn't actually compare all aspects of the FrameMetrics, that should be an exception and documented.

Attaching  a patch that fixes this, which also fixes rendering glitches when changing zoom levels in Firefox Mobile on Android.
Assignee

Updated

7 years ago
Blocks: 795259, 783368
Assignee

Comment 1

7 years ago
Makes the == operator compare each value in FrameMetrics, which fixes the metrics not updating when the resolution changes.
Attachment #667524 - Flags: review?(roc)
Duplicate of this bug: 797187
Confirmed that this fixes my problem.
Comment on attachment 667524 [details] [diff] [review]
Fix FrameMetrics == operator

Review of attachment 667524 [details] [diff] [review]:
-----------------------------------------------------------------

The outermost parentheses are useless. Remove them.
Attachment #667524 - Flags: review?(roc) → review+
Fixed and pushed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a34413a18f6
Target Milestone: --- → mozilla18
https://hg.mozilla.org/mozilla-central/rev/1a34413a18f6
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.