Closed Bug 797466 Opened 10 years ago Closed 10 years ago

Cursor artifacts in IME related to .com button and backspace, possibly related to scrolling text fields horizontally

Categories

(Firefox OS Graveyard :: Gaia, defect, P3)

x86_64
Linux
defect

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 799644
blocking-basecamp +

People

(Reporter: justin.lebar+bug, Assigned: cjones)

References

Details

-- Simplest STR on Otoro device:

 * Open browser app
 * Focus URL bar
 * Repeatedly click the ".com" button

Eventually I get an artifact where the cursor appears twice, like:

  .com.com.com|.com|

It goes away after a few seconds.

-- Alternate, worse behavior (but harder to reproduce): 

 * Type a bunch of letters and sprinkle in the ".com" button occasionally
 * I get situations where the cursor appears many times.  For instance:

   lksjdflksjdf|a|j|i|.com|

-- Alternate alternate behavior

 * Type a bunch of letters.
 * Press and hold backspace to delete a bunch of letters.
 * Immediately start typing again.  (No need to use the .com button.)
 * Again I see many cursors in my input field, like the alternate behavior above.
Chris, who should own this?
This is a pretty ugly polish bug, but I'm not sure it should block, since it does resolve itself after a few seconds.
blocking-basecamp: --- → ?
Thanks for filing; this has been happening for a while but I never got around to it.
Assignee: nobody → jones.chris.g
blocking-basecamp: ? → +
Priority: -- → P3
Strongly suspected to be the same underlying cause as bug 799644.
See Also: → 799644
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799644
You need to log in before you can comment on or make changes to this bug.