If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bing.com maps zoom keyboard shortcut no longer working

RESOLVED INVALID

Status

()

Core
Widget: Win32
RESOLVED INVALID
5 years ago
a year ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

15 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/0b774a1067fe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1 ID:20120905151427

Google Maps zoom keyboard shortcut[1] no longer working.

[1]http://onlinehelp.microsoft.com/en-us/bing/ff808521.aspx

Steps to reproduce:
 1. Open http://www.bing.com/maps/
 2. Click map
 3. Press "-(minus)" to zoom out
    --- nothing happens
 4. Press "Shift" + ";" key (Using Japanese 106 keyboard)
    --- nothing happens 

Actual results:
  nothing happens

Expected results:
  Working properly
(Reporter)

Comment 1

5 years ago
Err in comment #0
s/Google Maps/ Bing Maps/
Assignee: nobody → masayuki
This is not our bug even though the cause is bug 630810. The website need to change the key event handling code for the new internationalized keyCode value.
Anyway, I don't think '+' should work fine with JIS keyboard layout since it needs Shift key to input '+', we don't use DOM_VK_PLUS for the key.
Assignee: masayuki → nobody
Can you move this to Tech Evangelism then? And quote the part of the spec that supports our new behavior? Thanks.

Comment 5

5 years ago
Hi, can you let me know what is happening with this issue? Thanks.
Firefox: 50.0a1, Build ID: 20160705030222
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

I have tested this issue on the latest Firefox (47.0.1) release and the latest Nightly (50.0a1) build, but I could not reproduce it. I have opened the provided page, and I was able to zoom in and zoom out the map using the "+", "-" keys and the "Shift" + "+" and "Shit" + "-" keys combination. What should happen if the "Shift" + ";" key combination is pressed?

Alice, is this still reproducible on your end?
Flags: needinfo?(alice0775)
(Reporter)

Comment 7

a year ago
It does not work with main keyboard "-" and "Shift"+";" === "+".

maybe, MS does not consider 106 Japanese key board layout.
Anyway I think this is the site problem.   --- mark invalid.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(alice0775)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.