Status

()

Core
Networking: FTP
--
major
VERIFIED DUPLICATE of bug 99233
17 years ago
16 years ago

People

(Reporter: bkesuma, Assigned: bbaetz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; rv:0.9) Gecko/20010507
BuildID:    2001050716

I can not access any ftp://ftp.anything.com. I tried it with another Linux FTP
clients and they just work well. 

Reproducible: Always
Steps to Reproduce:
1. Go to any ftp://ftp.anything.com/pub/anywhere
2. And the browser will freeze. 


Actual Results:  The browser will freeze. The status bar showing
ftp://ftp.anything.com/pub/anywhere but it doesnt move at all.

Expected Results:  When I was using 0.80, it worked great. I can access any
anonymous FTP using Mozilla. 

I am using Red Hat 7.0. I installed mozilla from RPMS for Red Hat 7.0. The
packages I installed is, mozilla, mozilla-psm, mozilla-devel.

Comment 1

17 years ago
I have a build from today and I can access ftp sites.  I haven't made any
changes within the last few day to ftp.  hmm.
Severity: major → blocker
Keywords: qawanted

Comment 2

17 years ago
using linux build 2001052606 this problem does not exist... no hang or crash...

Comment 3

17 years ago
Reporter: can you try a recent build and see if the problem persists?

Also, are you behind a firewall or proxy?

Comment 4

17 years ago
Works for me, Build 2001053108, RedHat 7.0
(Reporter)

Comment 5

17 years ago
Yes I am behind the Firewall, but other FTP clients just work fine.

Comment 6

17 years ago
Works for me with linux build 2001053108 through an apache proxy.

Comment 7

17 years ago
I can't check from home, but if you have ftp working on your local Linux system,
try ftp to yourself. This will probably work, which means we need to find out
more about what is going on w/ the firewall. If you can do a trace, or find out
the type of firewall, that would be great.

Comment 8

17 years ago
Works for me 2001061108

Comment 9

17 years ago
Not a blocker...worksforme 061104
Severity: blocker → major

Comment 10

17 years ago
WFM 2001061308(MTrunk), Redhat GNU/linux 7.1 (seawolf), glibc 2.2.2-10, kernel
2.4.3, from a masqueraded IP
I recommend marking Works for me

Reporter: can you try with a more recent build

Comment 11

17 years ago
WFM Linux 2001062421
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Verified WFM
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

17 years ago
I just downloaded 0.92 and it still fail. I found some new hint though. 
If I access:
ftp://ftp.gtk.org/pub/
The status bar will display: Connecting to ftp.gtk.org
But nothing else happens.

ftp://anonymous:notEmail@ftp.gtk.org/pub/
The error reply from the FTP server tells me that my email is not valid will be
displayed.

ftp://anonymous:email%40domain.com@ftp.gtk.org/pub/
%40 is how you send @ from the browser. So it is a valid email. The status bar
again, will display: Connecting to ftp.gtk.org
But nothing happens.

But I can access:
ftp://user:passwd@ftp.wherever.com
If it is not anonymous, I can access it. 

Any clue? Please help :)
Oh yeah, I checked and filled in the "Send this email address for anonymous
password" in preferences by the way. 
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 14

17 years ago
reporter could you do a packet capture while try it? 

Comment 15

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted

Comment 16

17 years ago
is the only site you have trouble with ftp.gtk.org?
(Reporter)

Comment 17

17 years ago
No, it is all anonymous ftp://

Comment 18

17 years ago
this works for me.  if you reopen, please provide more information such as a
network log, proxy settings, ect.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: tever → benc

Comment 19

17 years ago
I am using 0.9.4 on Windows NT 4.0 and still have this problem.  I can ftp files
to and from ftp servers internally, but when I try to access any ftp server
outside our firewall it doesn't work.  It appears to start the connection, but
then moves to Done before anything is downloaded.  I can get a network capture
using Ethereal if this would help.  Thanks.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 20

17 years ago
to bbaetz :-)
Assignee: dougt → bbaetz
Status: REOPENED → NEW
(Assignee)

Comment 21

17 years ago
Can you try a current nightly? This was probably fixed by the fix to bug 99233.

Comment 22

17 years ago
I just got the latest build, and it does work now.  Thanks!
(Assignee)

Comment 23

17 years ago
OK then.

*** This bug has been marked as a duplicate of 99233 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 24

17 years ago
I just want to confirm. I downloaded 0.9.5 and there was no more problem. Thanks
to bbaetz!

Comment 25

16 years ago
VERIFIED:
was the same problem.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.