If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email] remove context menu

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: steveck)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

## Environment :
Otoro phone, build 2012-10-03 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= a3339652136fde9e5207e1bc1263a410c84f55fc 
* "releases-mozilla-central" revision= aecce9686d0b0e6ec25bb31e837eadace251a951
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1. launch email app
2. setup the email app with a hotmail account
3. go into email app
4. long tap on an email message 

## Expected :
1. context menu stays after you let go

## Actual :
1. context menu does not stay unless you drag your finger a little bit

## Note :
1. http://www.youtube.com/watch?v=HarE0asY5yk&feature=youtube_gdata_player
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Duplicate of this bug: 798707
(Assignee)

Comment 2

5 years ago
Hi, Casey
Based on the previous meeting conclusion, we've decided to remove the context menu and use value selector instead. If the decision is confirmed, could you please update the wireframe for this scenario? Many thanks.
Whiteboard: Need_UX_Input
Steve, the wire-frames have been updated for this.  Page 7 of main-main.pdf ("Multiple message select") clarifies the entry points now.
(Assignee)

Updated

5 years ago
Assignee: nobody → schung
(Assignee)

Comment 4

5 years ago
Created attachment 675024 [details]
https://github.com/mozilla-b2g/gaia/pull/5993
Attachment #675024 - Flags: review?(dkuo)
Attachment #675024 - Flags: review?(bugmail)

Updated

5 years ago
Priority: -- → P3
Summary: [email] context menu cannot be just long tap in order to make a selection → [email] remove context menu
Attachment #675024 - Flags: review?(dkuo)
Attachment #675024 - Flags: review?(bugmail)
Attachment #675024 - Flags: review+
r=asuth on https://github.com/mozilla-b2g/gaia/pull/5993
That pull request got bit-rotted, so I de-bit-rotted and created and pushed:
https://github.com/mozilla-b2g/gaia/pull/6066

Landed on gaia/master as:
https://github.com/mozilla-b2g/gaia/commit/e67ce1c76d70df33a9c0141243737842d9d09145
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: Need_UX_Input

Comment 6

5 years ago
Verified with Unagi, build 20121231070201
Unable to view context menu, by long tapping on the contact. Context menu has been removed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.