Closed Bug 797720 Opened 8 years ago Closed 8 years ago

IonMonkey: MonitorTypes is redundant if there's a type barrier

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 1 open bug)

Details

(Whiteboard: [ion:t])

Attachments

(1 file)

Attached patch PatchSplinter Review
MMonitorTypes is redundant if there's also a type barrier. Both check if the type is in the same set, and else call TypeScript::Monitor and bailout.

This seems to be a small v8-earley win.
Attachment #667858 - Flags: review?(dvander)
Attachment #667858 - Flags: review?(dvander) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a0c29c18fa7

Try: https://tbpl.mozilla.org/?tree=Try&rev=c7e794ac8926 (philor told me the Linux64 Red is bug 798225 and I can just ignore it, the ARMv6 reftest orange may be caused by the other patch I sent to Try, but not this one since we don't build IonMonkey on ARMv6).
Blocks: IonSpeed
https://hg.mozilla.org/mozilla-central/rev/1a0c29c18fa7
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.