Closed Bug 797902 Opened 7 years ago Closed 7 years ago

[tracking] Stand up a signing server for apps

Categories

(Marketplace Graveyard :: API, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2012-10-18

People

(Reporter: andy+bugzilla, Assigned: rtilder)

References

Details

In bug 793876 we created (or are in the process of) creating a temporary signing service for apps. For that we aren't using the HSM or anything fancy. We are using xpisign and hope that will work (we have to test that end to end).

As discussed at a meeting, we'd like to set up a proper signing service, that's outside of the marketplace process, utilises the HSM and provides lots of functionality, such as signing for reviews.

This tracking bug is for the implementation of that.
Assignee: nobody → rtilder
Depends on: 797907
Hey Ryan - let Andy and I know if there is anything you need for this. Thanks!
Target Milestone: --- → 2012-10-18
I think this is done, or else it's a dupe of bug 818641 which is deploying the signing service in production.  Calling this fixed but let me know if I'm missing something.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 957451
You need to log in before you can comment on or make changes to this bug.