Selecting awesome bar suggestion for intranet top-level domain starts google search

RESOLVED DUPLICATE of bug 690307

Status

()

RESOLVED DUPLICATE of bug 690307
6 years ago
6 years ago

People

(Reporter: kamilkaczm, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

1. Set up an intranet DNS server with a custom top-level domain, say, "my-domain". Some website is hosted there.
2. Went to http://my-domain/some/page
3. Closed the tab
4. Typed "my-domain" in the address bar. 
5. A suggestion for my-domain/some/page popped up. Selected it, pressed Enter.



Actual results:

A google search for the phrase "my-domain/some/page" was opened.


Expected results:

Should have navigated to http://my-domain/some/page

Extra info:
* Mind the presence of a hyphen in the domain name. Maybe that's to blame?
* Selecting the suggestion and manually prepending the address with "http://" does the trick. But keeping doing it drove me crazy enough to switch to Chrome while at work.
The google search is only triggered if you get a DNS error or a connection timeout.

Do you ever loaded something over https on this domain ?

Do you get the same behavior if you use "my-domain./some/page" (additional dot) instead ?
What happens if you disable the domain guessing and keyword search ?
http://www.brainonfire.net/blog/turn-off-domain-guessing-and-keyword-search-in-firefox/
(Reporter)

Comment 2

6 years ago
Sorry for writing the issue from memory, without sufficient research. It seems the problem occurs only when the URL contains a space - encoded as %20 but displayed in the bar simply as a space. But it still does not occur on normal Internet websites, even when their URL contain %20.

Also turns out, the title I gave the bug may be a little misleading, since the issue occurs also when I type the whole address manually, without using the suggestion. 

No, I don't use https, just HTTP authentication. I'm not sure if it's relevant.

When I add the dot I'm indeed not redirected to google (I do get http 400 invalid host name instead, but it's fine, I guess).

Trying these two settings from your link: the problem stops occurring when keyword.enabled is set to false, browser.fixup.alternate.enabled has no effect.
the space is the important information and that makes it to a dupe of bug 690307

btw: "http://example/" and "http://example./" are equivalent
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690307
You need to log in before you can comment on or make changes to this bug.