In the "download phase" of the stub installer without an internet connection, the stub installer should eventually time out and report an error

VERIFIED FIXED in Firefox 20

Status

()

Firefox
Installer
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: jsmith, Assigned: rstrong)

Tracking

Trunk
Firefox 22
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified, firefox22 verified, firefox-esr17 wontfix, b2g18 wontfix, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: [stub=])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Steps:

1. Without a network connection, launch the stub installer
2. Select to install

Expected:

In a reasonable amount of time, I would expect an error to be fired to indicate that a network connection is required to download the installation resources. Even better, if we detect sooner rather than later, then that'll give the user warning that a network connection is required for this installation.

Actual:

The installer starts entering the downloading phase. It spins infinitely trying to download the resources with no warning or error at all.
(Reporter)

Updated

6 years ago
Blocks: 322206
(Reporter)

Comment 1

6 years ago
I think this blocks ship, mainly cause we have to deal with the "no internet connection" use case. Spinning infinitely probably isn't the right way to go about this.
Whiteboard: [stub+]
(Reporter)

Comment 2

6 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> I think this blocks ship, mainly cause we have to deal with the "no internet
> connection" use case. Spinning infinitely probably isn't the right way to go
> about this.

Robert - Do you agree or disagree?
(Reporter)

Updated

6 years ago
Whiteboard: [stub+] → [stub?]
(Reporter)

Comment 3

6 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Jason Smith [:jsmith] from comment #1)
> > I think this blocks ship, mainly cause we have to deal with the "no internet
> > connection" use case. Spinning infinitely probably isn't the right way to go
> > about this.
> 
> Robert - Do you agree or disagree?

Actually, I'm going to change my mind on the bug here - the behavior isn't terrible on what happens, even though we don't timeout. We should try to fix this, but it isn't showstopping.
Whiteboard: [stub?]
(Reporter)

Updated

6 years ago
Whiteboard: [stub=]
Duplicate of this bug: 809117
Pushed to mozilla-central in bug 811573
https://hg.mozilla.org/mozilla-central/rev/216ec69cc531
Assignee: nobody → robert.bugzilla
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Pushed to mozilla-aurora in bug 811573
https://hg.mozilla.org/releases/mozilla-aurora/rev/189f9d9f856c
status-b2g18: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-firefox21: --- → fixed
status-firefox22: --- → fixed
status-firefox-esr17: --- → wontfix
status-b2g18-v1.0.0: --- → wontfix
Created attachment 722128 [details]
Stub-Installer Error Dialog

I confirm the fix is verified on Latest Nightly Stub-Installer (2013-06-03). I will verify on Aurora tomorrow because push from Comment 6 will appear only in tomorrow Aurora Stub-Installer.
status-firefox22: fixed → verified
Per comment #8 also changing status to verified
Status: RESOLVED → VERIFIED
(In reply to Robert Strong [:rstrong] (do not email) from comment #9)
> Per comment #8 also changing status to verified

Should I verify on FF 20 and 21? as I mentioned on comment 8?
It is the same code so I don't think it is necessary though it wouldn't hurt to also verify aurora.
I confirm the fix is verified on FF 20b4 and Latest Aurora 21.a2 (2013-03-07) too.
status-firefox20: fixed → verified
status-firefox21: fixed → verified
Robert, is this supposed to be a general error dialog? (see comment 8 for screenshot). The dialog doesn't say anything that would suggest that the problem lies with the internet connection. 

The flow also seems a bit strange. The OK button doesn't suggest the action which would be executed next: attempting to display a page without network connectivity.

Current flow is:
No internet connection, the error dialog appears 
a) select OK =>> the Firefox download page is opened with the default browser
-the page can't be displayed as the user doesn't have an internet connection
-the download page links to builds for every channel, including the stub - or the user already has the downloaded item. This would suggest that the problem lies in the builds and not in the internet connection.
b) Selecting Cancel closes the dialog and the installer.
Flags: needinfo?(robert.bugzilla)
(In reply to Virgil Dicu [:virgil] [QA] from comment #13)
> Robert, is this supposed to be a general error dialog? (see comment 8 for
> screenshot). The dialog doesn't say anything that would suggest that the
> problem lies with the internet connection. 
Yes and new strings will be added in the future
Flags: needinfo?(robert.bugzilla)
You need to log in before you can comment on or make changes to this bug.