Google DevTools slideshow crashes in mozilla::FrameLayerBuilder::UpdateDisplayItemDataForFrame

RESOLVED DUPLICATE of bug 795826

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 795826
5 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({crash, regression, reproducible})

18 Branch
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox17 unaffected, firefox18 affected)

Details

(crash signature, URL)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-4c6294b5-b433-488b-8b6e-7d6c22121005 .
============================================================= 

STR:
1. Load Google DevTools slideshow: http://www.igvita.com/slides/2012/devtools-tips-and-tricks/
2. Hold down the right arrow or space bar to rapidly advance the slides

RESULT:
Crash!

This is a regression in Nightly 18.0a1 build 2012-09-29. I bisected tinderbox builds of mozilla-inbound and I believe this is the regression range:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
(Reporter)

Updated

5 years ago
Summary: crash in mozilla::FrameLayerBuilder::UpdateDisplayItemDataForFrame → Google DevTools slideshow crashes in mozilla::FrameLayerBuilder::UpdateDisplayItemDataForFrame
Version: unspecified → 18 Branch

Comment 1

5 years ago
On Windows: bp-bf0b81dd-42e6-459c-a924-241462121005.

It's bug 795826 with STR.
Blocks: 539356, 795826
Crash Signature: [@ mozilla::FrameLayerBuilder::UpdateDisplayItemDataForFrame] → [@ mozilla::FrameLayerBuilder::UpdateDisplayItemDataForFrame] [@ nsTHashtable<mozilla::FrameLayerBuilder::DisplayItemDataEntry>::s_EnumStub(PLDHashTable*, PLDHashEntryHdr*, unsigned int, void*)]
OS: Mac OS X → All
Does this reproduce in the 10/4 nightly?  The likely fix landed by then.

Comment 3

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #2)
> Does this reproduce in the 10/4 nightly?
Yes. See the Build ID in crash reports.

Updated

5 years ago
No longer blocks: 795826
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795826
You need to log in before you can comment on or make changes to this bug.