If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Security icon in the taskbar is not reflecting secure status of IMAP or NNTP.

VERIFIED DUPLICATE of bug 93571

Status

SeaMonkey
MailNews: Message Display
P2
major
VERIFIED DUPLICATE of bug 93571
17 years ago
13 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: Cavin Song)

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+], URL)

Build ID: 2001050904, Windows 2000 and Mac OS 9.1

Summary: Security icon in the taskbar is not reflecting secure newsgroup.

Steps to Reproduce:

1.  Add a secure newsgroup server such as secnews.netscape.com.
2.  Go into Account Manager and change the checkbox "Use secure connection
(SSL)" to be true.
3.  Exit and restart Mozilla.
4.  Notice that the newsgroup has the secure icon in the folder pane, and is
indeed running on port 563 (as shown by doing a netstat)
5.  Look at the statusbar/taskbar's lock icon.

Expected Results:

As with https:// pages and secure IMAP, the icon should be in a locked state,
and should be gold, not blue.

Actual Results:

Icon never changes state
Keywords: nsbeta1
Eek, secure IMAP doesn't do this either, but NS 4.7x does, Karen is this a known
bug?
QA Contact: esther → stephend
changing scope of bug, since this is seen on secure IMAP, too. (port 993)
Severity: normal → major
Component: Networking - News → Mail Window Front End
Keywords: 4xp
Summary: Security icon in the taskbar is not reflecting secure newsgroup. → Security icon in the taskbar is not reflecting secure status of IMAP or NNTP.

Comment 3

17 years ago
moving to 0.9.2
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2
cc'ing mscott / bryner.

I'll have to go see how (and when) the lock changes state for browser.

Comment 5

17 years ago
imap does this...or at least it used too. I hooked it up myself. I'm not sure
why news wouldn't work as it's along for the ride.....something may have regressed.
I believe this is actually not our bug (or not partially).  See bug 80468, which
just had a fix checked in by Darin Fisher.

Comment 7

17 years ago
reassigning to cavin
Assignee: sspitzer → cavin
Priority: P3 → P2

Comment 8

17 years ago
adding [PDT+]
Whiteboard: [nsbeta1+] → [nsbeta1+][PDT+]

Comment 9

17 years ago
moving to 0.9.3. cc'ing darin in case he has any advice.
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 10

17 years ago
not sure that i have much to add since bug 80468 only had to do with problems
in our http implementation.

Updated

17 years ago
Keywords: nsenterprise

Updated

17 years ago
Whiteboard: [nsbeta1+][PDT+] → [nsbeta1+]

Comment 11

16 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
*** Bug 89839 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
adding nsenterprise+
Keywords: nsenterprise → nsenterprise+

Comment 14

16 years ago
You may want to make this a dup of bug 93571
dup indeed.

*** This bug has been marked as a duplicate of 93571 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Thanks for letting me know about the other bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.