document.referrer is not consistent.

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: Prashant Desale, Unassigned)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
document.referrer is not consistent, even if the referrer is same.
Funny thing is it current referrer gets replaced by child's [child window] 
form. action value.

BUILDS:xpcdom as well as regular trunk.

STEPS TO REPRODUCE
1] Please visit URL above.
2] IMPORTANT: Please carefully read & understand everything mentioned on the 
testcase.
3] Click button "Start document.referrer Test"
4] Child window showing document.referrer would be opened 5 times.


EXPECTED RESULTS:
All 5 times child window should show 
"document.referrer : http://bubblegum/desale/cgi-bin/first.cgi"

ACTUAL RESULTS:
first time child window shows 
"document.referrer : http://bubblegum/desale/cgi-bin/first.cgi"
But Other 4 times it shows 
"document.referrer : http://bubblegum/desale/cgi-bin/second.cgi"
[This is wrong. How can document.referrer change to form.action value of child 
window ?]
Future.
Target Milestone: --- → Future
(Reporter)

Comment 2

16 years ago
SEVERITY = MEDIUM [(1)No Crash, (2)Complete functional failure, (3)No Cosmetic 
failure]
VISIBILITY = MEDIUM [(1)There can be real website usage. (2)Gets one point of 
compatibility with other browsers since it works very well on NS4.x. (3)Gets one 
more point on compliance with adopted techonology which  is JS] 

PRIORITY = VISIBILITY * SEVERITY

Hence Priority = p3

adding word "qawanted" because I'm setting this priority on available data & if 
someone feels otherwise then please investigate this more & feel free to change 
this priority.
Keywords: qawanted
Priority: -- → P3
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
Is that testcase still accessible?  If not, I'm going to mark this worksforme...
I don't think so, and I doubt there's anywhere here at AOL who knows.

The server has a DNS entry, but pinging it results in TTL expiring in transit.
Tha AOL firewall kills ICMP packets, you know....  Used to be you couldn't ping
any mozilla.org stuff either.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Not to _internal_ destinations, it doesn't.

We're class A NAT'd.  Anything within 10.xxx.xxx.xxx resolves, as long as it has
correct information.

(I've set up a full lab here...)

Anyway, I'm very doubtful anything useful can be found in this building...
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.