New Firefox cannot display page with JPEG 2000 images

RESOLVED DUPLICATE of bug 36351

Status

()

defect
RESOLVED DUPLICATE of bug 36351
7 years ago
2 years ago

People

(Reporter: spark74, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I tried to open a page of the wenker atlas e.g.
http://137.248.81.135/diwa/ECW.asp?ID1=137
and my firefox 15.0.1 on Windows 7.


Actual results:

It showed the DiWa page but with a large black window. 


Expected results:

It should show a map (dialect map for the German language).
The old firefox 3 showed the correct map.
Internet Explorer 8 showed the page correctly.
(Reporter)

Comment 1

7 years ago
Displaying the Wenker Atlas page correctly with the iexpolrer 8

Comment 2

7 years ago
Do you have the Image Web Server ECW JPEG 2000 Plug-in (which is required for this page) ? Or anther one to display jpeg-2000 files ?
(Reporter)

Comment 3

7 years ago
Did you manage to see tha map with your firefox. I have ECW Progress Bar 3.4.0.242, ECW Toolbar 3.4.0.242, Image Web Server Plugin 3.4.0.242, Java Development Toolkit 6.0.350.10, Java TM Platform SE 6 U35 6.0.350.10.
I tried to install ERMapperWebPluginsSetup from the side and will test it.
My firefox 3.6.12 on Solaris do not need these plugins and show the page correctly.
(Reporter)

Comment 4

7 years ago
I installed ERMapperWebPluginsSetup (should contain/be the Image Web Server ECW JPEG 2000 Plug-in) but the list of relevant plugins seems to be the same and does not help for firefox 15 on Windows.
Could you please try to do it yourself? Did it work with your firefox 15?

Comment 5

7 years ago
I don't have the plugin, and I'm not seeing anything.

> My firefox 3.6.12 on Solaris do not need these plugins and show the page
> correctly.

Firefox has never supported JPEG 2000 (and never will).

Updated

7 years ago
Summary: New Firefox cannot display page → New Firefox cannot display page with JPEG 2000 images
(Reporter)

Comment 6

7 years ago
The funny thing is that firefox 3.6.12 on Solaris works without any special plugin. It has a java plugin but it can display the page. Maybe you can test it?
(Reporter)

Comment 7

7 years ago
It seems that the ECWB plugin is only requiered for Windows as the Solaris firefox can load the first page with it's java plugin.

Comment 8

6 years ago
(In reply to spark74 from comment #7)
> It seems that the ECWB plugin is only requiered for Windows as the Solaris
> firefox can load the first page with it's java plugin.

I installed ERDASWebPluginsSetup and jre-7u13-windows-i586, but my firefox 19 beta6 also cannot display page with JPEG 2000 images, at the same time, IE8 can.
https://github.com/kripken/j2k.js

Someone please do the work to hook it up.

/be
(In reply to Brendan Eich [:brendan] from comment #9)
> https://github.com/kripken/j2k.js
> 
> Someone please do the work to hook it up.

Do you mean something along the lines of what I proposed in [1]? Or something internal, specific to j2k? Seems like if we do the latter, we might as well do the former.

I think this is worthwhile work - it just needs nontrivial resourcing, possibly from busy people. But you are certainly in the position to make those resources appear if you choose to. ;-)

[1] https://groups.google.com/forum/#!topic/mozilla.dev.planning/K9hAhd16Y2A

Comment 11

5 years ago
Dupe of bug 36351

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: JPEG2000
You need to log in before you can comment on or make changes to this bug.