Closed Bug 798628 Opened 8 years ago Closed 7 years ago

[Metro] Crashes when opening

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: irae, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [startupcrash] DirectX?)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121005040203

Steps to reproduce:

Using nightly-elm branch, configured nightly as default metro browser.
Launch it from home (tiles) screen.


Actual results:

Crashes within 2 seconds or so.

In event viewer I collected the following message:

App DefaultBrowser_NOPUBLISHERID!EEFEA8717BC47F65 did not launch within its allotted time.


Expected results:

Open main window in metro style.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: crash
OS: Windows 8 → Windows 8 Metro
Version: 18 Branch → Trunk
Product: Firefox → Firefox for Metro
Do you know whether your system supports DirectX 10?  This crash might be related to bug 806436.
Flags: needinfo?(irae)
I use Windows 8 most of the time inside a VMWare Fusion VM. No DirectX 10 support is available at the time for VMWare Fusion. Nevertheless, I have another workstation at work that was unable to run Firefox Metro and a friend of mine was unable too. I will check thease machines and his (none are virtualized) for Directx 10 support and report back later.
Flags: needinfo?(irae)
I have DirectX 11 and the same problem.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: [startupcrash]
No longer blocks: metrov1triage
confirmed: false
crashes with same event error.
Whiteboard: [startupcrash] → [startupcrash] DirectX?
(In reply to cpcs from comment #5)
> confirmed: false
> crashes with same event error.

Now that we have the full omtc backend going, are you still seeing this cpcs?
Duplicate of this bug: 806436
Duplicate of this bug: 843282
(In reply to Jim Mathies [:jimm] from comment #6)
> (In reply to cpcs from comment #5)
> > confirmed: false
> > crashes with same event error.
> 
> Now that we have the full omtc backend going, are you still seeing this cpcs?

No doesn't crash anymore jim:)
Great!
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
No longer blocks: metro-startup
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.