Closed Bug 798636 Opened 7 years ago Closed 7 years ago

[Gallery] Crash upon finishing loading all of my pictures, including a picture just taken from the camera

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-basecamp:+)

RESOLVED WORKSFORME
blocking-basecamp +

People

(Reporter: jsmith, Assigned: dougt)

Details

(Keywords: crash)

Attachments

(1 file)

Build:

* Device: Otoro
* Gaia: 5f7dbe06490e6b52a356e033f52fb31c0fa0e2d0
* Mozilla Central: ddc8eeb3f9b9ee04d9f74b4f60522eb4530a4a6f

Steps:

1. Take a picture with the camera
2. Load the gallery - wait until it finishes loading

Expected:

The gallery pictures should load from the sdcard, including the pictures taken.

Actual:

I get a crash after all of the pictures load from my sdcard. I can reproduce this twice with my sdcard.
Keywords: crash
Also - how exactly do I get a crash dump from adb?
blocking-basecamp: --- → ?
Doug, would you be able to try to get a crash stack here so that we can find an appropriate owner?
Assignee: nobody → doug.turner
blocking-basecamp: ? → +
pretty hard to reproduce this.  any ideas?
Flags: needinfo?(jsmith)
(In reply to Doug Turner (:dougt) from comment #3)
> pretty hard to reproduce this.  any ideas?

Sorry for the delay. Working on this now.
Flags: needinfo?(jsmith)
Flags: needinfo?(jsmith)
Keywords: qawanted
QA Contact: jsmith
FWIW... I haven't been able to reproduce this issue.  10/11 build. otoro
http://dl.dropbox.com/u/1827165/DCIM%20and%20screenshots.zip contains my pictures for my device. I'll retest to see if I can reproduce with today's build.
Flags: needinfo?(jsmith)
Keywords: qawanted
i can not reproduce.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
I can reproduce on the 10/19 build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Attached file Logcat
Doug, can you reproduce with Jason's pictures?
Flags: needinfo?(doug.turner)
(In reply to Andrew Overholt [:overholt] from comment #10)
> Doug, can you reproduce with Jason's pictures?

Hist comment above indicates he cannot. I'll try again on today's build.
And now apparently I cannot reproduce. Oh well.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(doug.turner)
Resolution: --- → WORKSFORME
@Jason, looks like you encounter the same problem as in bug 805114. How many picture you have in your sdcard?
(In reply to Shih-Chiang Chien [:schien] from comment #13)
> @Jason, looks like you encounter the same problem as in bug 805114. How many
> picture you have in your sdcard?

84 pictures. And yeah, that bug looks like what I hit.
You need to log in before you can comment on or make changes to this bug.