Unable to play video on mobile Novinky.cz and Super.cz

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Pavel Franc - Mozilla.cz, Assigned: adamopenweb)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff][country-cz][sitewait], URL)

(Reporter)

Description

6 years ago
Flash video plays normally in default Android browser. In Firefox it shows only message about "Video not available for this device".

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Hardware: All → ARM
server-side sniffing will send either a <video> tag or a simpler page with a "video not available" message.

This UA string triggers video content:
User-Agent: Mozilla/5.0 (Linux; U; Android 4.0.4; nb-no; HTC_One_X Build/IMM76D) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
..and it seems they look for specific device keywords, like in this case "HTC_One_X".
Whiteboard: [serversniff][country-cz]
super.cz demo:

http://m.super.cz/202174-tahle-rozkosna-blondynka-je-dcerou-martina-maxy-nejsvalnatejsi-cesky-zpevak-poprve-vyvedl-sve-deti.html

Pretty much same implementation (including looking for same token in UA) but serves a <a href="/video?sznu=
80MrrgjuZd9BjO43&amp;id=2341033" style="display:block;"><
span class="play"></span> .. tag instead of an embedded <video> to "supported" devices.

Are super.cz and novinky.cz run by the same company? If yes, having one bug to cover both may be OK - if not, a separate bug should be filed for super.cz
Whiteboard: [serversniff][country-cz] → [serversniff][country-cz][contactready]
Whiteboard: [serversniff][country-cz][contactready] → [serversniff][country-cz]
Whiteboard: [serversniff][country-cz] → [serversniff][country-cz][contactready]
(Assignee)

Comment 3

4 years ago
Seznam.cz runs these two sites plus sport.cz https://bugzilla.mozilla.org/show_bug.cgi?id=798770.
(Assignee)

Comment 4

4 years ago
Firefox OS is getting served basic mobile version for the group of sites. Firefox Android looks to be getting sent to the main site which is responsive. Firefox Android also plays videos on some of the sites depending on the source video. As Hallvord mentioned they are looking for device names in the UA string.

I reached out to the Business Department (reklama@firma.seznam.cz), the main site has an option for English. Will see if we get a response.
Assignee: nobody → astevenson
Whiteboard: [serversniff][country-cz][contactready] → [serversniff][country-cz][sitewait]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 798770
(Assignee)

Comment 6

4 years ago
Response: try the live chat support, I was in the queue but it closed at 16:30. Will try again.
(Assignee)

Comment 7

4 years ago
Another bug for this group of sites: https://bugzilla.mozilla.org/show_bug.cgi?id=795088
Status: NEW → ASSIGNED

Updated

4 years ago
See Also: → bug 795088

Comment 8

4 years ago
tested today still the same.
Seems OK now with Firefox for Android. Pavel, can you please confirm?

Unfortunatelly with Firefox OS I am able to play only Sport.cz and Super.cz videos, not Novinky.cz.
Flags: needinfo?(pcvrcek)
Yes I can confirm that.
Flags: needinfo?(pcvrcek)
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Do we have a separate bug for novinky.cz video problems on FxOS? Let's not loose track of that problem :))
Of course - bug 1182858. Sorry to have nagged you :)
You need to log in before you can comment on or make changes to this bug.