Closed Bug 798773 Opened 7 years ago Closed 7 years ago

Use OMXClient in GonkRecorder

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 803471

People

(Reporter: sotaro, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

GonkRecorder create OMX instance within current process and use it. It request high privilege to WebApp's process.

In bug 798202, I created a patch to move back OMX insatance to mediaserver process.
If gonk decides to apply it, it is better doing same also in GonkRecorder.
Depends on: 798202, 776062
OS: Windows 7 → Gonk
Hardware: x86_64 → ARM
change GonkRecorder to use OMXClient like in android.
Even when we apply attachment 668771 [details] [diff] [review], we can not remove high privilege from camera application's process. The application use camera hw, and it also require high privilege...

We could also move back camera hw to mediaserver, though more work is necessary than this bug is doing. But not too difficult.

I do not have access to otoro device, I use my device to run FirefoxOS. On my hardware, camera app do not work correctly. After I start up the app, preview is updated only once, after that there is no update to preview. At first I need to address the problem :-(
Blocks: 803471
Depends on: 808907
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803471
No longer blocks: 803471
You need to log in before you can comment on or make changes to this bug.