Closed Bug 798786 Opened 9 years ago Closed 7 years ago

Wrong/misleading GFX info in about:support with OMTC turned on (Linux)

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s - ---

People

(Reporter: kairo, Unassigned)

References

Details

I just turned on OMTC in a self-built Linux Nightly from today, using the steps in http://mozillagfx.wordpress.com/2012/10/06/how-to-help-testing-off-main-thread-compositing/ (I had layer acceleration on for a while already, and it's looking quite good, so I was happy to step to the next level of testing).

I wondered if about:support would show me if I have OMTC on, but found out it doesn't have an entry for that. What I saw though, was that it now shows values that look like acceleration was off and WebGL not present, or at least it shows "no information" there. I can confirm though that WebGL and acceleration work (draw-fps works and BananaBread works).

Here's the about:support info with OMTC on:

  Graphics

        Adapter Description
        Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Desktop

        Device ID
        Mesa DRI Intel(R) Sandybridge Desktop

        Driver Version
        3.0 Mesa 8.0.4

        GPU Accelerated Windows
        0/5 Basic no information

        Vendor ID
        Tungsten Graphics, Inc

        WebGL Renderer
        no information

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none

Here's the section with layers enabled but OMTC off:

  Graphics

        Adapter Description
        Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Desktop

        Device ID
        Mesa DRI Intel(R) Sandybridge Desktop

        Driver Version
        3.0 Mesa 8.0.4

        GPU Accelerated Windows
        5/5 OpenGL

        Vendor ID
        Tungsten Graphics, Inc

        WebGL Renderer
        no information

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none

Hmm, looks like "WebGL Renderer" is broken in both cases (BTW, no matter if I call up BananaBread before looking at that page or not, just tried to make sure). Is that a different bug?
"GPU Accelerated Windows" seems to break only with OMTC in any case, though.
FYI - WebGL Renderer : no information in about:support was reported in bug 795701
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
I think this is fixed.
Yes, I think so:

Adapter Description	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Desktop
Asynchronous Pan/Zoom	none
Device ID	Mesa DRI Intel(R) Sandybridge Desktop
Driver Version	3.0 Mesa 10.5.3
GPU Accelerated Windows	0/5 Basic (OMTC)
Vendor ID	Intel Open Source Technology Center
WebGL Renderer	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Desktop
windowLayerManagerRemote	true
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.