Last Comment Bug 798789 - Enable gcc -Werror=conversion-null for gcc >= 4.5 for comm-central (port bug 778980)
: Enable gcc -Werror=conversion-null for gcc >= 4.5 for comm-central (port bug ...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: Thunderbird 19.0
Assigned To: :aceman
:
Mentors:
Depends on: 778980
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 07:32 PDT by :aceman
Modified: 2012-10-12 04:53 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (1.64 KB, patch)
2012-10-06 10:42 PDT, :aceman
standard8: review+
Details | Diff | Splinter Review

Description :aceman 2012-10-06 07:32:39 PDT
Apply this to comm-central if it is useful.

+++ This bug was initially created as a clone of Bug #778980 +++

To make gcc's NULL/nullptr warnings fatal like clang's nullptr errors, we may want to add -Werror=conversion-null to Linux's CFLAGS/CXXFLAGS for gcc >= 4.5. (The -Wconversion-null flag was new in gcc 4.5.)

If a developer overlooks these gcc warnings, then they may not realize their code change will break the OS X's clang build until they push to the tryserver. This is a waste of developer time and tryserver resources.
Comment 1 :aceman 2012-10-06 10:42:40 PDT
Created attachment 668800 [details] [diff] [review]
patch

Here is the patch. Archaeopteryx, please try it on a try server (linux only is enough). I did not get any failures, but I compile with many components disabled.
Comment 2 Sebastian Hengst [:aryx][:archaeopteryx] 2012-10-06 13:20:12 PDT
Thunderbird-Try run: https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=408d5cf11a05
Builds are green
Comment 3 :aceman 2012-10-06 13:30:15 PDT
Comment on attachment 668800 [details] [diff] [review]
patch

The build try server was done for Thunderbird only. Can anybody try Seamonkey?
Comment 4 Mark Banner (:standard8) 2012-10-09 02:54:49 PDT
SeaMonkey Try run: https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=752bf0e94218
Comment 5 :aceman 2012-10-09 03:38:56 PDT
Thanks for the build.

There is a configure error:
configure: error: Unrecognized extension provided to --enable-extensions: venkman.

That does not seem caused by this patch.
Comment 6 Mark Banner (:standard8) 2012-10-09 03:47:36 PDT
Comment on attachment 668800 [details] [diff] [review]
patch

The first SeaMonkey run I got wrong, but the second should work:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=1e27f1fd450a
Comment 7 Mark Banner (:standard8) 2012-10-09 03:47:58 PDT
(and that's r+ assuming that run passes).
Comment 8 :aceman 2012-10-09 03:57:52 PDT
Now an "Internal server error" and another run with "abort: connection ended unexpectedly" ???
Comment 9 Sebastian Hengst [:aryx][:archaeopteryx] 2012-10-09 04:10:48 PDT
If you this happens during |hg pull -u|:
That happens often. The more changesets, the more likely. Just try again.
Comment 10 Mark Banner (:standard8) 2012-10-09 04:25:50 PDT
If they are blue, they'll automatically be re-run. The builds finished off red in stage-package, but that's because SM is expecting to package the extensions that I disabled (rather than having them pulled). So the actual compilations did pass. That's about the best we can do with SM on try server.
Comment 11 :aceman 2012-10-09 05:04:39 PDT
OK, thanks. So I take it that the build works.

If any breakage appears later please point me to it.
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-10-09 17:42:44 PDT
https://hg.mozilla.org/comm-central/rev/ccb28f98f40a
Comment 13 :aceman 2012-10-12 04:50:38 PDT
Ryan, any reason you did not close this bug after check-in?
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-10-12 04:53:56 PDT
Nope, just forgot. Thanks.

Note You need to log in before you can comment on or make changes to this bug.