Demo "Like" and "View" counts decrease over time

RESOLVED WONTFIX

Status

developer.mozilla.org
Demo Studio / Dev Derby
P1
major
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: lazygnomeprod, Unassigned)

Tracking

Details

(Whiteboard: [triaged])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPNTDF; .NET4.0C; Zune 4.7)

Steps to reproduce:

problem is seen when listing demos


Actual results:

demo view count going down on my demo:
balloons in a forest


Expected results:

it should be 444 or more
(Reporter)

Comment 1

6 years ago
Oh, and please remove my user agent string from the description, it has nothing to do with the bug. At least do this one thing for me.
Hey lazygnomeprod.

I will watch your demo over the next couple of days to try to figure out why the view count is going down. When did you start seeing this behavior?
(Reporter)

Comment 3

6 years ago
444 was the highest number on my demo. It was on the day I reported this.
Confirmed.

October 9: 374 views
October 23: 245 views

That's a pretty significant jump. I will be sure we look into this. Thanks for catching it, lazygnomeprod.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

6 years ago
Hi John,
Dont worry that much, maybe this is not that evil as it seems.
If it is decrementing (and it stays like this forever), it is not that big of a problem.
It annoyed me though when I saw it, even I got 2 likes less. It should be 5 now.
I am learning too in the process. You may let me know if you learnt something.
Regards, LGP
Summary: Demo views disappearing - 444 -> 412 on my demo → Demo "Like" count decreases over time
Same thing seems to happen with views.
Any idea what's going on here, Luke? Is the data being lost or simply not reported correctly? Crossing fingers for the latter, so that we can restore the action counts to what they should be.
Summary: Demo "Like" count decreases over time → Demo "Like" and "View" counts decrase over time
We periodically delete "anonymous" likes & views that are older than 2 months. That is, those recorded for visitors who are not logged in. Here's the relevant code:

    https://github.com/mozilla/kuma/blob/master/apps/actioncounters/cron.py#L31-L40

It was done as part of bug 672875. I think this might have started because the DB table was getting huge. I want to say there was more discussion of it, but can't remember other reasons why. :(

Some options:

* Increase the 2 months time period, say maybe to 12 months.
* Find some other way to measure likes & views not based on a DB row per action.
Keeping all likes and views permanently would be ideal. Some users like to browse the top-viewed and top-liked demos of all time, and many contributors like to compete for those positions. With inaccurate numbers, neither of these is really possible.

Not sure what's needed from the development side, but from an interface point of view all we really need is the totals so option 2 could work.
Summary: Demo "Like" and "View" counts decrase over time → Demo "Like" and "View" counts decrease over time
Thinking out loud... Another thing we could do is have summary tables with running tallies of anonymous actions. 

Every 2 months (or whatever), sum up all the discrete anonymous actions and add that to the summary tally. Then, delete the discrete anonymous action rows. That would let us keep the count stable, yet clean up the table.

The downside would be that those anonymous users could get a second chance at registering a like or view, since the discrete rows serve as rough identifying details to prevent double-voting.
Would be nice if we could get this fixed soon. The like and view counts are used when determining which demos to show on the homepage.
Blocks: 925145

Updated

5 years ago
No longer blocks: 925145
Priority: -- → P1

Updated

5 years ago
Severity: normal → major
Whiteboard: [triaged]

Comment 13

3 years ago
Demo Studio is being retired from MDN and archived as of end January 2016
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.