Embedded Videos will not play on Fox News, NBC, Bill O'Reilly

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Gary King, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Details

(Whiteboard: [mozTouchEvent])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 668914 [details]
BO.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121007030539

Steps to reproduce:

Visit sites and the embedded videos will not play. Videos in Various Forums also will not play
http://video.foxnews.com/v/1826592412001/debbie-wasserman-schultz-caught-in-a-lie/?playlist_id=87262&intcmp=obnetwork
[url=http://www.foxnews.com/on-air/oreilly/index.html]http://www.foxnews.com/on-air/oreilly/index.html[/url]


Actual results:

Videos did not play


Expected results:

Video should have played

Comment 2

6 years ago
The video in comment#0 works when set dom.w3c_touch_events.enabled = false(need restart)
So this is regressed by bug 726615.
Blocks: 726615
(Reporter)

Comment 3

6 years ago
In reply to comment 2, it does play when that is set to false but the bug still needs to be fixed. The average user will not know this.
(In reply to Alice0775 White from comment #2)
> The video in comment#0 works when set dom.w3c_touch_events.enabled =
> false(need restart)
> So this is regressed by bug 726615.

726615 landed last month, so something recent must be setting this off rather than the fault of that patch.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 5

6 years ago
(In reply to Gary King from comment #3)
> In reply to comment 2, it does play when that is set to false but the bug
> still needs to be fixed. The average user will not know this.

New W3C touch events will be disabled by default in Aurora on Windows, see bug 798821.

I confirm I don't get anymore "Error: Source not supported." with dom.w3c_touch_events.enabled = false.
status-firefox17: --- → unaffected
tracking-firefox18: --- → ?
(Reporter)

Comment 6

6 years ago
Does it still not need to be addressed in Nightly Build 18?

Comment 7

6 years ago
(In reply to Gary King from comment #6)
> Does it still not need to be addressed in Nightly Build 18?

Please stop spamming the bug. Bugzilla is not a complaints forum. It is for identifying potential bugs, the steps to reproduce the bug, ID the regression range, discussing ways to fix the bug and submitting the fix(es).

Besides, all Alice was doing as providing a key piece of information for whoever has to fix the bug. No one ever said this bug should not be fixed.
(Reporter)

Comment 8

6 years ago
Ray, PO. I created this bug and I was only asking a question. I am not spaming anything if anyone is it is you! I was responding to this :

New W3C touch events will be disabled by default in Aurora on Windows, see bug 798821.

Comment 9

6 years ago
Read bug 798821, they are discussing about the best solution (disabled in Aurora/enabled in Nightly, sniffing etc).
(Reporter)

Comment 10

6 years ago
To comment 9, thanks

Updated

6 years ago
status-firefox18: --- → affected
tracking-firefox18: ? → +
This is site bug.

If no createTouch, it uses Flash as video player.  But if supports, it uses mp4 video.  So since Chrome supports MP4 as video codec, even if using Chrome 24 w/ touch device, it works.
(Reporter)

Comment 12

5 years ago
To comment 11. This is not a site bug. Those videos will play using Firefox 15 or any other browser. We are NOT dealing with Chrome24.
(In reply to Gary King from comment #12)
> To comment 11. This is not a site bug. Those videos will play using Firefox
> 15 or any other browser. We are NOT dealing with Chrome24.

Touch event supports on Firefox 18 or later.  If any browser supports touch event, current foxnews.com uses MP4 as video codec instead of Flash.  If not support, it still uses Flash.  If Opera for desktop supports touch event, same issue will occur.

Chrome for Windows suppors touch event if there is touch device.  so even if touch enabled, it can see video as MP4 video.  (Chrome supports MP4 codec)

foxnews.com should stop check document.createTouch to choose whether MP4 or Flash.  This check is incorrect.  They should use user-agent or nother way.

Updated

5 years ago
Assignee: nobody → english-us
Component: Untriaged → English US
Product: Firefox → Tech Evangelism
Version: 18 Branch → unspecified
(In reply to Makoto Kato from comment #13)
> They should use user-agent or nother way.
They should use canPlayType(). User-Agent sniffing is as bad as testing a random property.
(Reporter)

Comment 15

5 years ago
To comment 14, this is more than one site. Is the Net to change to accommodate  a simple change in Firefox 18?[quote]dom.w3c_touch_events.enabled = false(need restart)[/quote]
(In reply to Gary King from comment #15)
We are discussing workaround (disabling touch events on Windows) in bug 798821. But it doesn't mean sites do not have to fix their bug. For example, we can't disable touch events on Android and MetroFirefox.
(Reporter)

Comment 17

5 years ago
To comment 16. Then maybe this report should be closed and referenced to bug 798821. As long as it gets resolved, the method is not that important to me.
This bug has been morphed into Tech Evangelism bug to track the site bug.
Please add yourself to CC list of bug 798821 if you have the interest.
Unfortunately there is no way the reporter unsubscribes from the reported bug.

Updated

5 years ago
No longer blocks: 726615

Updated

5 years ago
Depends on: 806805

Updated

5 years ago
tracking-firefox18: + → -
Whiteboard: [mozTouchEvent]
(Reporter)

Comment 19

5 years ago
Original problem is now working in The latest Nightly build.
(Reporter)

Comment 20

5 years ago
This should be marked resolved. It works for me in Fx21
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard

Updated

2 years ago
Blocks: 806805
No longer depends on: 806805
You need to log in before you can comment on or make changes to this bug.