Closed Bug 798990 Opened 7 years ago Closed 7 years ago

Don't call EnsureTarget in nsCanvasRenderingContext2DAzure::GetCanvasLayer

Categories

(Core :: Canvas: 2D, defect)

18 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: roc, Assigned: roc)

References

Details

Attachments

(2 files)

No description provided.
Attachment #668985 - Flags: review?(ajones) → review+
Attachment #669742 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/ca18c9aedc67
https://hg.mozilla.org/mozilla-central/rev/52fdb83ca8b8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 668985 [details] [diff] [review]
fix

Review of attachment 668985 [details] [diff] [review]:
-----------------------------------------------------------------

EnsureTarget during painting is not safe, so we need this fix on Aurora, or we'll have regressions.
Attachment #668985 - Flags: approval-mozilla-aurora?
Comment on attachment 669742 [details] [diff] [review]
Part 2: nsCanvasRenderingContext2DAzure::EnsureTarget must ensure that a full layer transaction occurs

Review of attachment 669742 [details] [diff] [review]:
-----------------------------------------------------------------

EnsureTarget during painting is not safe, so we need this fix on Aurora, or we'll have regressions.
Attachment #669742 - Flags: approval-mozilla-aurora?
Would you mind addressing the nomination form questions, even if you clear out the format? We're looking for regressing bug #, risk, user impact, etc.
Attachment #668985 - Flags: approval-mozilla-aurora?
Comment on attachment 668985 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 773460
User impact if declined: Potentially mysterious crashes on/near startup similar to bug 773097
Testing completed (on m-c, etc.): landed on m-c a few days ago
Risk to taking this patch (and alternatives if risky): low. no real alternatives.
String or UUID changes made by this patch: none
Attachment #668985 - Flags: approval-mozilla-aurora?
Comment on attachment 669742 [details] [diff] [review]
Part 2: nsCanvasRenderingContext2DAzure::EnsureTarget must ensure that a full layer transaction occurs

Review of attachment 669742 [details] [diff] [review]:
-----------------------------------------------------------------

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 773460
User impact if declined: Potentially mysterious crashes on/near startup similar to bug 773097
Testing completed (on m-c, etc.): landed on m-c a few days ago
Risk to taking this patch (and alternatives if risky): low. no real alternatives.
String or UUID changes made by this patch: none
Comment on attachment 668985 [details] [diff] [review]
fix

Sounds like if we see any major regressions over the next 11 weeks, we can just disable bug 773460 for FF18. Approving for Aurora 18.
Attachment #668985 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #669742 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.