bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Image Saving Problem - Default goes as PDF extension




6 years ago
5 years ago


(Reporter: iamjayakumars, Unassigned)


18 Branch

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [testday-20121221])


(1 attachment)



6 years ago
Created attachment 669131 [details]
Screenshot from 2012-10-08 19:06:32.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121007064007

Steps to reproduce:

I try to save images from the website, its saves as "filename.PDF"
I tried with different website.
but default it goes to " .PDF " extension instead of PNG or JPG

Actual results:

Saving image as .PDF file extension.
instead of JPG/PNG

Expected results:

It must save image as with image format(JPG/PNG)
Always provide exact steps to reproduce including URL and how you are saving images.
The behavior could depend on the server and there are multiple ways to save an image

Comment 2

6 years ago
I checked with different website.
Even i checked with http://blog.mozilla.org
right click on the image and "Save Image As"
i tried this method to save an image.

it happen after i downloaded the PDF file using "Downthemall".
Please open about:support and click on the Profile folder: Show Folder.
Close Firefox and rename the file "mimeTypes.rdf" (e.g.mimeTypes.old) on your profile and restart Firefox. Does it work now ?

Comment 4

6 years ago
i think its Downthemall Add-on problem
I can't reproduce the bug on the latest Nightly.
WFM  (on the latest Nightly)

Comment 7

5 years ago
[testday=20121221] edwardb

Visited an arbitrary web-site with images.

Right-clicked on an image, the right-click menu gave the option to Save image...
It was a jpg file, and immediately, firefox gave the option with the .jpg, .jpeg filter active.

The file contents were jpeg.

Visited a webpage with .png files.
Right-clicked the image and was given the choice to Save image ...
But Firefox gave the option with the .jpg and .jpeg filter active.  (must be some mistake...)
Saved the file and forced .png at the end of it.
Went and saved the file again using the suggested .jpeg filter and extension.

In the rox file manager, the image files saved were examined under "Properties"
All of them had jpeg contents.  hmmm...

Revisited this bug page and noticed the screenshot of the bug was an .png file.
Right-clicked and Save image ...  Firefox gave me the .png filter active and displayed the folder where the previous images were saved.  The file was then saved.

Using Rox again, confirmed the .png image of the screenshot.  And again, confirmed the other images were .jpeg's.

This bug has been RESOLVED.


5 years ago
Whiteboard: [testday-20121221]

Comment 8

5 years ago
(In reply to Edward B from comment #7)
> This bug has been RESOLVED.

You need to decide what it has been resolved as: WORKSFORME, INVALID or FIXED. :)


5 years ago
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 9

5 years ago
[testday-20121221] edwardb 
Resolution: INVALID would be the best since i didn't look at the source code nor submitted the fix...
You need to log in before you can comment on or make changes to this bug.