If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Redundant popupset in bookmarks sidebar panel makes context menu not work

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla0.9.6
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Fabian is seeing this (but I'm not), but the popupset is redundant anyhow and 
there could be other cruft in my tree that's preventing me from seeing the bug. 
Attaching a patch to remove the old popupset.
Created attachment 33820 [details] [diff] [review]
patch to remove redundant popupset
Status: NEW → ASSIGNED

Comment 2

17 years ago
r=dr

Comment 3

17 years ago
yep fine
i'll ask on IRC later whether anyone can reproduce the strangeness I'm seeing
with the sidebar/ptoolbar context menus

Comment 4

17 years ago
Linux:
I built with this patch: it didn't change anything. None of the context menu
items in sidebar bookmark tab work. The only thing this patch seemed to cause
was that context-menu randomly appeared in the middle of browser instead of near
the bookmark where i clicked.

Comment 5

17 years ago
this is just to remove useless code, it will not fix anything.
There is no more popupset called "popupset" so it should not away.
Again this will not fix anything.

Comment 6

17 years ago
sr=alecf on the patch (even if it doesn't fix the bug)
Easy. 
Priority: -- → P3
Target Milestone: --- → mozilla0.9.6
Oops, this has been checked in. At least, the popupset isn't in bm-panel.xul
anymore...
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.