If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove Permission.txt

RESOLVED FIXED in mozilla24

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Martijn Wargers (dead))

Tracking

Trunk
mozilla24
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
I couldn't find 'idle' in the Permission.txt file.

But if I understand the source code, correctly, it is checking for an 'idle' permission.
http://mxr.mozilla.org/mozilla-central/source/dom/base/Navigator.cpp#675

So 'idle' should be added to the Permission.txt list, right?
(Assignee)

Comment 1

4 years ago
Created attachment 751515 [details] [diff] [review]
patch

Hrm, there is a lot more in extensions/cookie/Permission.txt that's not there, that is there in dom/apps/src/PermissionsTable.jsm .
Even the doc at https://developer.mozilla.org/en-US/docs/Web/Apps/App_permissions seems to have more info.

Is this Permission.txt still useful?
Attachment #751515 - Flags: review?(mounir)
Comment on attachment 751515 [details] [diff] [review]
patch

Review of attachment 751515 [details] [diff] [review]:
-----------------------------------------------------------------

FWIW, I do not think this file is very useful. I would definitely r+ a patch that removes it.
Attachment #751515 - Flags: review?(mounir) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 751636 [details] [diff] [review]
git patch

Ok, let's do that then.
Attachment #751515 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #751636 - Flags: review?(mounir)
Comment on attachment 751636 [details] [diff] [review]
git patch

Review of attachment 751636 [details] [diff] [review]:
-----------------------------------------------------------------

Asking Gregor to review that change to in case of this file has a role I wasn't aware of.
Attachment #751636 - Flags: review?(mounir)
Attachment #751636 - Flags: review?(anygregor)
Attachment #751636 - Flags: review+
Attachment #751636 - Flags: review?(anygregor) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/dd2ffe93fb2f
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Assignee: nobody → martijn.martijn
Summary: 'idle' WebAPI is not mentioned in Permission.txt → Remove Permission.txt
https://hg.mozilla.org/mozilla-central/rev/dd2ffe93fb2f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Duplicate of this bug: 818767
You need to log in before you can comment on or make changes to this bug.