Closed Bug 799441 Opened 7 years ago Closed 7 years ago

install gio extension

Categories

(Firefox Build System :: General, defect)

x86_64
FreeBSD
defect
Not set

Tracking

(firefox18 fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: jbeich, Assigned: glandium)

References

Details

Attachments

(1 file, 2 obsolete files)

My firefox install:

$ ls $prefix/lib/firefox/components
binary.manifest
libbrowsercomps.so
libmozgnome.so

$ cat $prefix/lib/firefox/components/binary.manifest
binary-component libmozgnome.so
binary-component libnkgio.so
binary-component libbrowsercomps.so
Attachment #669466 - Flags: review?(karlt)
Thinking about it, maybe we just want to remove FORCE_SHARED_LIB from extensions/gio/Makefile.in. What do you think, Karl?
(In reply to Mike Hommey [:glandium] from comment #2)
> Thinking about it, maybe we just want to remove FORCE_SHARED_LIB from
> extensions/gio/Makefile.in. What do you think, Karl?

That sounds a step in the right direction, but would also need changes to toolkit/library/Makefile.in.  See also bug 794698.
Comment on attachment 669466 [details] [diff] [review]
Bug 799441 - Install GIO extension, everywhere GNOMEVFS2's one is.

This is correct; it makes the build system do what was intended.

If someone wants to put together a patch to build this into libxul, then that would be a better fix.  I guess EXTRA_DSO_LDOPTS could then also be removed.
Attachment #669466 - Flags: review?(karlt) → review+
(I don't know what effect it has)
Is this something thunderbird should have as well? http://mxr.mozilla.org/comm-central/source/mail/installer/package-manifest.in#750
(In reply to Magnus Melin from comment #5)

I'm not clear who or how many people use this.  The gio extension is there to provide the same functionality as the old gnomevfs extension, which is to support loading from smb: and sftp:.

If thunderbird isn't missing the gnomevfs extension, it probably won't miss the gio extension.  Bug 682838 may make the gio extension more useful, though.
Blocks: 800137
Yes Thunderbird does (some people use smb), I filed bug 800137.
Attached patch Build GIO module in libxul (obsolete) — Splinter Review
Attachment #670274 - Flags: review?(karlt)
Assignee: nobody → mh+mozilla
Attachment #670274 - Flags: review?(karlt) → review+
It's kind of gross, but we already have other extensions directories in tier_platform_dirs. Previous iteration didn't actually work because extensions are normally built after libxul.
Attachment #670577 - Flags: review?(ted.mielczarek)
Attachment #670577 - Flags: review?(karlt)
Attachment #670274 - Attachment is obsolete: true
Comment on attachment 670577 [details] [diff] [review]
Build GIO module in libxul

This looks fine to me if you can find the right place to remove extensions/gio so that make is not run twice in that directory.  Best to wait and see whether Ted thinks this is a step in the right direction.
Attachment #670577 - Flags: review?(karlt) → review+
(In reply to Karl Tomlinson (:karlt) from comment #10)
> Comment on attachment 670577 [details] [diff] [review]
> Build GIO module in libxul
> 
> This looks fine to me if you can find the right place to remove
> extensions/gio so that make is not run twice in that directory.

That's what the configure.in change does.
Attachment #669466 - Attachment is obsolete: true
Comment on attachment 670577 [details] [diff] [review]
Build GIO module in libxul

Review of attachment 670577 [details] [diff] [review]:
-----------------------------------------------------------------

I really want to get this out of extensions/...
Attachment #670577 - Flags: review?(ted.mielczarek) → review+
(In reply to Ted Mielczarek [:ted] from comment #12)
> I really want to get this out of extensions/...

Let's do that in a followup
https://hg.mozilla.org/mozilla-central/rev/d243048bc966
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Duplicate of this bug: 800137
Comment on attachment 670577 [details] [diff] [review]
Build GIO module in libxul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 713802
User impact if declined: Feature regression on linux builds for smb:// and sftp:// protocols
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): The code was built but not installed ; with the patch it is linked in libxul. As long as it builds on m-c (which it does), there's no risk.
String or UUID changes made by this patch: None
Attachment #670577 - Flags: approval-mozilla-aurora?
Attachment #670577 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.