GCLI jsb command should revert jsbBraceStyleDesc, jsbBraceStyleManual strings

RESOLVED FIXED in Firefox 18

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jwalker, Assigned: miker)

Tracking

unspecified
Firefox 19
Points:
---

Firefox Tracking Flags

(firefox18 fixed)

Details

Attachments

(1 attachment)

It's my understanding that the UI will be not as nice as it could be, but not actually broken by this change.
Assignee: nobody → mratcliffe
So, basically undoing these changes:
# LOCALIZATION NOTE (jsbBraceStyleDesc) A very short description of the
 # 'jsb <braceStyle>' parameter. This string is designed to be shown
 # in a menu alongside the command name, which is why it should be as short as
 # possible.
-jsbBraceStyleDesc=Collapse, expand, end-expand, expand-strict
+jsbBraceStyleDesc=Select the coding style of braces
 
 # LOCALIZATION NOTE (jsbBraceStyleManual) A fuller description of the
 # 'jsb <braceStyle>' parameter, displayed when the user asks for help
 # on what it does.
-jsbBraceStyleManual=The coding style of braces. Either collapse, expand, end-expand or expand-strict
+jsbBraceStyleManual=<p class="nowrap">The coding style of braces. Select from one of the following:</p><ul><li>collapse<br/><pre>if (x == 1) {\n  ...\n} else {\n  ...\n}</pre></li><li>expand<br/><pre>if (x == 1)\n{\n  ...\n}\nelse\n{\n  ...\n}</pre></li><li>end-expand<br/><pre>if (x == 1) {\n  ...\n}\nelse {\n  ...\n}</pre></li><li>expand-strict<br/><pre>if (x == 1)\n{\n  return // This option can break scripts\n  {\n    a: 1\n  };\n} else {\n  ...\n}</pre></li></ul>
Created attachment 669511 [details] [diff] [review]
Reverted
Attachment #669511 - Flags: review?(jwalker)
Attachment #669511 - Flags: review?(jwalker) → review+
We also need this landed in Aurora
Whiteboard: [land-in-fx-team]

Comment 4

5 years ago
Can we expidite the landing of this? And Alex, I support landing this on aurora.
https://hg.mozilla.org/integration/fx-team/rev/0759a7d8b78b
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0759a7d8b78b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 19
Comment on attachment 669511 [details] [diff] [review]
Reverted

[Approval Request Comment]
Bug caused by (feature/regressing bug #): String change
User impact if declined: None, but localizers will struggle to change the complex string (jsbBraceStyleManual)
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): Zero (string change)
String or UUID changes made by this patch: jsbBraceStyleDesc & jsbBraceStyleManual
Attachment #669511 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #7)
> String or UUID changes made by this patch: jsbBraceStyleDesc &
> jsbBraceStyleManual

In Axel's absence, including Stas to see if this is a desirable fix to pick up for Aurora.
(In reply to Alex Keybl [:akeybl] from comment #8)
> (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #7)
> > String or UUID changes made by this patch: jsbBraceStyleDesc &
> > jsbBraceStyleManual
> 
> In Axel's absence, including Stas to see if this is a desirable fix to pick
> up for Aurora.

I take comment 4, to be support from Axel.
(In reply to Joe Walker [:jwalker] from comment #9)
> (In reply to Alex Keybl [:akeybl] from comment #8)
> > (In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #7)
> > > String or UUID changes made by this patch: jsbBraceStyleDesc &
> > > jsbBraceStyleManual
> > 
> > In Axel's absence, including Stas to see if this is a desirable fix to pick
> > up for Aurora.
> 
> I take comment 4, to be support from Axel.

Ha fair enough. Missed that.

Updated

5 years ago
Attachment #669511 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Tim Taubert [:ttaubert] from comment #6)
> https://hg.mozilla.org/mozilla-central/rev/0759a7d8b78b
This patch has not changed l10n string names, so localizers will not notice change in l10n. Please, change string names. At least for aurora.
(In reply to Alexander L. Slovesnik from comment #11)
> (In reply to Tim Taubert [:ttaubert] from comment #6)
> > https://hg.mozilla.org/mozilla-central/rev/0759a7d8b78b
> This patch has not changed l10n string names, so localizers will not notice
> change in l10n. Please, change string names. At least for aurora.

The idea of this patch is to back out some late changes that didn't change string names. So this is a revert.
(In reply to Joe Walker [:jwalker] from comment #12)
> (In reply to Alexander L. Slovesnik from comment #11)
> > (In reply to Tim Taubert [:ttaubert] from comment #6)
> > > https://hg.mozilla.org/mozilla-central/rev/0759a7d8b78b
> > This patch has not changed l10n string names, so localizers will not notice
> > change in l10n. Please, change string names. At least for aurora.
> 
> The idea of this patch is to back out some late changes that didn't change
> string names. So this is a revert.

Several locales has already translated these late changes - http://mxr.mozilla.org/l10n-mozilla-aurora/search?find=%2F&string=jsbBraceStyleManual%3D%3Cp+class%3D%22nowrap%22%3E
How are they gonna notice that these changes have been reverted?

Comment 14

5 years ago
Pushed to Aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/a02e939d3088
status-firefox18: --- → fixed
You need to log in before you can comment on or make changes to this bug.