[New Tab Page] Leaving Private Browsing Mode stops New Tab Page preloading

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: morpheus3k+bugzilla, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
Leaving the Private Browsing Mode will kill the Preloading of the New Tab Page (With "browser.newtab.preload" set to true).

Steps to reproduce:
1. set browser.newtab.preload to true
2. restart Firefox
3. activate Private Browsing Mode
4. Leave Private Browsing Mode
5. Open new Tab

Expected Result:
Instant display of the new Tab Page

Actual Result:
Firefox behaves like browser.newtab.preload set to false.
Reporter

Updated

7 years ago
Blocks: 791670

Comment 1

7 years ago
WFM on the 10/15 Nightly.

Morpheus3k, can you reproduce this issue with a clean profile?
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(morpheus3k+bugzilla)
Reporter

Comment 2

7 years ago
Yes, I can reproduce this behavior with a clean profile and the given steps on Windows 7 and OS X 10.8 on 3 different machines.
Flags: needinfo?(morpheus3k+bugzilla)
Reporter

Comment 3

6 years ago
Since "Implement per-window Private Browsing" is active, this bug does not apply anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.