Closed Bug 799507 Opened 8 years ago Closed 8 years ago

TypeError exception when running remote reftest

Categories

(Testing :: Mozbase, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wlach, Assigned: wlach)

Details

Attachments

(1 file)

Right now we're seeing the following junk in remotereftest

REFTEST INFO | runreftest.py | Running tests: start.

Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/logging/__init__.py", line 776, in emit
    msg = self.format(record)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/logging/__init__.py", line 654, in format
    return fmt.format(record)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/logging/__init__.py", line 436, in format
    record.message = record.getMessage()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/logging/__init__.py", line 306, in getMessage
    msg = msg % self.args
TypeError: %d format: a number is required, not str
(https://tbpl.mozilla.org/php/getParsedLog.php?id=15950429&full=1&branch=mozilla-inbound)

As far as I can tell, this is actually harmless as we don't currently consider it an error, but it can obviously throw us off of real issues (like the one in the full log) when they happen. The source of this problem is the fact that mozdevice's processExist function returns a string, not an integer. Let's fix that.
Comment on attachment 669570 [details] [diff] [review]
Always return integers for pids/userids for getProcessList and processExist

Review of attachment 669570 [details] [diff] [review]:
-----------------------------------------------------------------

and we have tests.
Attachment #669570 - Flags: review?(jmaher) → review+
Pushed: https://github.com/mozilla/mozbase/commit/fd94278ee72224200a28edb05434533c4df2188f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
There was a minor problem with the implementation wrt devicemanagerADB, which I fixed:

https://github.com/mozilla/mozbase/commit/c84d6da5669d9846719dac6e001348786b010874
Duplicate of this bug: 800191
You need to log in before you can comment on or make changes to this bug.