Add a color-picker for CSS color values

RESOLVED DUPLICATE of bug 889638

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 889638
6 years ago
4 years ago

People

(Reporter: sys.sgx, Unassigned)

Tracking

18 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121005155445

Steps to reproduce:

Feature suggestion:
A color-picker, like in chromium, would give the ability to select new colors with realtime update on the webpage.

The color-picker would be shown by clicking on a color-box of the css value, in Style Panel, and offer the full color range as well as opacity.

There could also be another window that will provide alternative similar color hues, based on the color the current element.
(Reporter)

Updated

6 years ago
Component: Untriaged → Developer Tools: Inspector
OS: Windows Vista → All
Version: 16 Branch → 18 Branch
(Reporter)

Updated

6 years ago
Hardware: x86 → All
Something on these terms :

https://dl.dropbox.com/u/3250186/colorpicker.jpg

The screenshot is from my extension User Style Manager, which uses Firefox's source-editor in CSS mode, and the Color picker is an open source , that I have modified to work with the source-editor.
(Reporter)

Comment 2

6 years ago
It's nice, but I think we'll need something simpler looking. (see: chromium)
Just for easy use by people.
Does chromium by default has a color picker ?
(Reporter)

Comment 4

6 years ago
Created attachment 669655 [details]
Chromium Color Picker
(Reporter)

Comment 5

6 years ago
yes, see the attached image, from google.com
We can make it even better, by having something like a button that will auto-suggest different hues;  I think this will be very useful for production.
Well, I am not a fan of Chrome's UI, so I will never like the design.

Anyways, here are the 3 other modes of the same Color Picker in the same add-on.

https://dl.dropbox.com/u/3250186/diff.jpg

Not saying that it should be this feature rich, might be overkill even.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 889638
You need to log in before you can comment on or make changes to this bug.