Closed Bug 799576 Opened 7 years ago Closed 7 years ago

datazilla errors shouldn't print 'ERROR'

Categories

(Testing :: Talos, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Unassigned)

References

Details

Attachments

(1 file)

Some datazilla errors output things like:
NOISE: Outputting datazilla results to https://datazilla.mozilla.org/talos
NOISE: datazilla: https//datazilla.mozilla.org/talos; oauth=True
Error posting to https://datazilla.mozilla.org/talos: 500 INTERNAL SERVER ERROR
Error posting to https://datazilla.mozilla.org/talos: 500 INTERNAL SERVER ERROR

"ERROR" is a string we look for to indicate problems with the test: https://mxr.mozilla.org/build/source/buildbotcustom/steps/talos.py#108

As I understand it, Datazilla errors should be silent, so it would be great if we could change this error string to be something we don't catch in Buildbot.
So part of the problem is that INTERNAL SERVER ERROR is what HTTP 500 is o_O  We could lower-case this for talos (and everything else that uses datazilla) if that helps.  That said, it is the hack of all hacks
Can't we just catch the exception and print out something else? That doesn't seem very hacky to me.
so the problem is we don't know the string of the exception.  In general, you will want to know why you've failed to post to datazilla: 403 UNAUTHORIZED, 500 SERVER ERROR, etc . The string message is not set in talos or datazilla client:

http://hg.mozilla.org/build/talos/file/5f421eb0d1ed/talos/output.py#l472
Attached patch error vs ERRORSplinter Review
Attachment #669643 - Flags: review?(jmaher)
Attachment #669643 - Flags: review?(jmaher) → review+
Confirmed locally that this does print lowercase: 

NOISE: Outputting talos results => {'datazilla_urls': ['https://datazilla.mozilla.org/talos']}
NOISE: Outputting datazilla results to https://datazilla.mozilla.org/talos
NOISE: datazilla: https//datazilla.mozilla.org/talos; oauth=False
Error posting to https://datazilla.mozilla.org/talos: 500 internal server error
Error posting to https://datazilla.mozilla.org/talos: 500 internal server error


Obviously I can't test buildbot's response locally. Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=544e994dc2b7
with jmaher's blessing, going ahead and pushing: http://hg.mozilla.org/build/talos/rev/402d205b6946
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 799574
Depends on: 801633
You need to log in before you can comment on or make changes to this bug.